Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re: Cannot create directory while compiling perl 5.16.1

by shlomif (Beadle)
on Sep 09, 2012 at 10:52 UTC ( #992574=note: print w/replies, xml ) Need Help??


in reply to Cannot create directory while compiling perl 5.16.1

Hi szabgab,

can you please provide the following information:

  1. Which distibution and version does this Linux box run?
  2. How did you invoke "sh Configure"? Any special configuration parameters?
  3. If you only do sh Configure -de -Dprefix=$HOME/apps/perl/bleadperl does it work properly?
  4. Is this Linux machine at a remote hosting? If so - which?

Hopefully I or others will be able to help you after getting this information.

  • Comment on Re: Cannot create directory while compiling perl 5.16.1

Replies are listed 'Best First'.
Re^2: Cannot create directory while compiling perl 5.16.1
by szabgab (Priest) on Sep 09, 2012 at 11:01 UTC
    It tells me it is a "Red Hat Enterprise Linux Server release 6.3 (Santiago)" but I suspect it might be CentOS.

    ./Configure -des -Dprefix=/a/it/perl5-15.1

    The /a is an NFS. My suspicion is that the usernames and ids have some issues. I run as user "abc" but the files I create have owner "def" and group "xyz". Also I noticed user "abc" has two entries in /etc/passwd

    The local IT team is working on fixing the userids and usernames, but I am not sure if this is the source of the problem,

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://992574]
help
Chatterbox?
[LanX]: did you spam before? :)
LanX has to go/
[ambrus]: I hope we didn't mess up the spam filter rules again.
[ambrus]: Our spam filter rules disallow links to certain domains, and some suspicious pharses that have appeared in previous spam advertising cheap online whatevers.
[LanX]: some servers were lagging today, so I suppose the root cause
[LanX]: ambrus no recent patches
[Petroza]: no i haven't posted anything before. It was a more or less long question with a specific issue. I did post a title and the links i added where only part of the element i was searching within the code (so no purpose other than the question itself).
[1nickt]: Petroza can you go back in your browser to the preview screen, redact the links, and try to submit again?
[LanX]: copy and paste the text into your Petroza's scratchpad please
[Petroza]: yes I'll do that. instead of the url I'll write "link"

How do I use this? | Other CB clients
Other Users?
Others about the Monastery: (11)
As of 2017-10-17 15:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My fridge is mostly full of:

















    Results (233 votes). Check out past polls.

    Notices?