Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight

Re^5: LWP Can't POST to HTTPS

by dorko (Parson)
on Sep 12, 2012 at 17:47 UTC ( #993268=note: print w/replies, xml ) Need Help??

in reply to Re^4: LWP Can't POST to HTTPS
in thread LWP Can't POST to HTTPS

Can you please tell me how to enable trace/debug? I found LWP::Debug, but that's depreciated.



-- Yeah, I'm a Delt.

Replies are listed 'Best First'.
Re^6: LWP Can't POST to HTTPS
by Anonymous Monk on Sep 12, 2012 at 17:56 UTC

    From Long delay with Crypt::SSLeay and LWP, the thing you linked and read and tried a "solution" from, the diagnostic steps

    #!/usr/bin/perl -- use LWP::Simple ; use IO::Socket::SSL qw(debug3); get( q{} ); get( q{} ); __END__
      Mea maxima culpa. I'm sorry, when I said "looking at" I should have said "skimmed". Admittedly, I didn't read that. Thank you.

      This is the results of IO::Socket::SSL qw(debug3); for the POST.

      DEBUG: .../IO/Socket/ new ctx 32651216 DEBUG: .../IO/Socket/ socket not yet connected DEBUG: .../IO/Socket/ socket connected DEBUG: .../IO/Socket/ ssl handshake not started DEBUG: .../IO/Socket/ Net::SSLeay::connect -> -1 DEBUG: .../IO/Socket/ SSL connect attempt failed with unkn +own error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/ fatal SSL error: SSL connect attempt +failed with unknown error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/ IO::Socket::INET configuration faile +d error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/ free ctx 32651216 open=32651216 DEBUG: .../IO/Socket/ OK free ctx 32651216
      Again, any help will be appreciated. Thanks for your time.



      -- Yeah, I'm a Delt.

        Looks to me like you edited that. I get

        DEBUG: .../IO/Socket/ ssl handshake not started DEBUG: .../IO/Socket/ ok=1 cert=18003144 DEBUG: .../IO/Socket/ ok=1 cert=18832752 DEBUG: .../IO/Socket/ ok=1 cert=18830608 DEBUG: .../IO/Socket/ ok=1 cert=18829200 DEBUG: .../IO/Socket/ scheme=www cert=18829200 DEBUG: .../IO/Socket/ cn=webco alt=2 DEBUG: .../IO/Socket/ Net::SSLeay::connect -> 1

        Sure I'm using an older version of IO::Socket::SSL ( 1.58 ) compiled against older version of OpenSSL , but I doubt that makes a difference

Re^6: LWP Can't POST to HTTPS
by Anonymous Monk on Sep 12, 2012 at 17:58 UTC

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://993268]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (7)
As of 2016-10-23 22:40 GMT
Find Nodes?
    Voting Booth?
    How many different varieties (color, size, etc) of socks do you have in your sock drawer?

    Results (302 votes). Check out past polls.