Beefy Boxes and Bandwidth Generously Provided by pair Networks
Do you know where your variables are?

Re^2: https request failing

by bethereu2 (Initiate)
on Sep 18, 2012 at 12:20 UTC ( #994273=note: print w/replies, xml ) Need Help??

in reply to Re: https request failing
in thread https request failing

Hi, I checked the env params:
env | grep proxy http_proxy=http://<company-proxy>.se:8080/ https_proxy=http://<company-proxy>.se:8080/ no_proxy=localhost,, .<companyname>.se,
In the perl script I used: no_proxy() should not proxy be skipped?
br, //mike

Replies are listed 'Best First'.
Re^3: https request failing
by marto (Bishop) on Sep 18, 2012 at 12:29 UTC

    That's worth investigating, but I'll leave that to you. Regardless I think the trailing slash may cause problems, which is why I suggested removing it.

      I don't know if you have solved it or not, but... I do have a problem that sounds like the one you experience. What I noticed is that when I am using GET (as one example) on an HTTP address, then the module uses both environment variable "http_proxy" and "no_proxy" (and everything works). However, when doing the same towards an https address, the module uses "https_proxy" (as expected), but it seems "no_proxy" settings aren't used. SO far I have no solution or workaround.

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://994273]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others about the Monastery: (7)
As of 2016-10-27 08:12 GMT
Find Nodes?
    Voting Booth?
    How many different varieties (color, size, etc) of socks do you have in your sock drawer?

    Results (355 votes). Check out past polls.