Beefy Boxes and Bandwidth Generously Provided by pair Networks
good chemistry is complicated,
and a little bit messy -LW
 
PerlMonks  

Re^3: Script using Getopt::Long running endlessly after beeing packaged by pp

by Anonymous Monk
on Oct 17, 2012 at 08:21 UTC ( #999484=note: print w/ replies, xml ) Need Help??


in reply to Re^2: Script using Getopt::Long running endlessly after beeing packaged by pp
in thread Script using Getopt::Long running endlessly after beeing packaged by pp

I don't understand why you checked the version

To show you what I am using

And I don't really understand, should I turn on the Perl debugger while running my script or the PAR debugger while packaging ?

I don't know, what are you trying to debug, the packing or the running? Where is the problem?

(And as I never turned on the debugger, what is the correct synthax ? PAR_GLOBAL_DEBUG=1 ?)

See help set or  help export depending on your platform, see Environment variable


Comment on Re^3: Script using Getopt::Long running endlessly after beeing packaged by pp
Select or Download Code
Re^4: Script using Getopt::Long running endlessly after beeing packaged by pp
by HJO (Acolyte) on Oct 17, 2012 at 08:31 UTC

    "I don't understand why you checked the version" To show you what I am using

    I meant the version of Module::ScanDeps, I'm not using it

    Where is the problem?

    Well actually I don't have the single idea... It may be an error while packaging the module, or simply an error during the running because the module Getopt::Long doesn't run very well after it gets packaged... I simply know that this module is the source of my issues, before packaging I can pass options, after I packaged, whether or not I try options, I got some error

    Ok for the environment variables, I'll test it soon (the two cases, the packaging and the running to be sure)

      I meant the version of Module::ScanDeps, I'm not using it

      Sure you are, its PAR dependency, and an important one

        Ok, I didn't know.

        So I tried to check the version of the three modules you gave me, and upgraded them so I'm basically in the same configuration than you, but I'm still getting errors... I'm afraid I misdjuged the error while reading more carefully the output :

        Compilation failed in require at script/script.pl line 8. BEGIN failed--compilation aborted at script/script.pl line 8.

        And in fact the rest of the errors listed are realted to DateTime::Format::Builder so I'm going to try to force install it again and recheck if everything's fine...

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://999484]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (5)
As of 2014-09-21 13:05 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (169 votes), past polls