in reply to Roll Call - How new is your Perl?

I am a lucky guy (maybe): I can decide what we use at work. It just forces me to take the time to build from scratch and install all required modules. My work usually involves working on HP-UX (and - loathe - AIX). I am one of the people making perl binary depots available for HP-UX, so I have to build it anyway. When I would depend on AIX/IBM for a working perl distribution, I'd probably be still using 5.6.0, as AIX/IBM don't care about open source. HP does a bit better, but still lack actual builds.

On production boxes - and thus the boxes of our customers, we currently run 5.14.2.

On my laptop I run the newest stable version as production, but with 135 versions of perl installed with various configuration options, I can check and use whatever I want, even nightly builds.

On my workstation, I run the latest stable (5.16.2 currently), which I use to test all company stuff on before I decide to move onward on the servers.

I do not care a single *beep* about Modern::Perl. If I have to install that on every single version of perl, most of them wouldn't work I guess and I don't see it offering more than what use 5.14.2; use warnings; already offers me. I will have to keep wondering what it was that the module offers me over that warrant its use: As from its man page "it may include additional core modules and pragmas". Thanks, but no thanks.

I used defined-or from 5.8.0 onward. As I maintained the patchset to enable that in 5.8.x, I just built my perls to include it.

I never use system-perl for anything production-like.


Enjoy, Have FUN! H.Merijn


Comment on Re: Roll Call - How new is your Perl?
Select or Download Code