in reply to Re: Installing Glib on Debian
in thread Installing Glib on Debian

install gobject/glib/pkg-config
I have all of that.

Note that if I didn't the configuration-step would already fail as MakeMaker checks for that.

But for whatever reason I only get a warning (something I dit not get on the other machine) and a .so is compiled but that does not seem to work. Unfortunately both perl-version and library-versions are slightly different on my other machine...


Comment on Re^2: Installing Glib on Debian
Re^3: Installing Glib on Debian
by Anonymous Monk on Feb 22, 2013 at 01:22 UTC
      You have what? Where is it?
      > pkg-config --libs gobject-2.0 -lgobject-2.0 -lglib-2.0 > find /usr/lib -name \*libglib-2.0\* /usr/lib/vmware-installer/2.0/lib/lib/libglib-2.0.so.0 /usr/lib/vmware-installer/2.0/lib/lib/libglib-2.0.so.0/libglib-2.0.so. +0 /usr/lib/vmware/lib/libglib-2.0.so.0 /usr/lib/vmware/lib/libglib-2.0.so.0/libglib-2.0.so.0 /usr/lib/x86_64-linux-gnu/libglib-2.0.a /usr/lib/x86_64-linux-gnu/libglib-2.0.so > find /usr/lib -name \*libgobject-2.0\* /usr/lib/vmware-installer/2.0/lib/lib/libgobject-2.0.so.0 /usr/lib/vmware-installer/2.0/lib/lib/libgobject-2.0.so.0/libgobject-2 +.0.so.0 /usr/lib/vmware/lib/libgobject-2.0.so.0 /usr/lib/vmware/lib/libgobject-2.0.so.0/libgobject-2.0.so.0 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0.3200.4 /usr/lib/x86_64-linux-gnu/libgobject-2.0.so /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 /usr/lib/x86_64-linux-gnu/libgobject-2.0.a > dpkg -l |grep libglib2.0- ii libglib2.0-0:amd64 2.33.12+really2.32 +.4-5 GLib library of C routines ii libglib2.0-bin 2.33.12+really2.32 +.4-5 Programs for the GLib library ii libglib2.0-cil 2.12.10-3 + CLI binding for the GLib utility library 2.12 ii libglib2.0-cil-dev 2.12.10-3 + CLI binding for the GLib utility library 2.12 ii libglib2.0-data 2.32.0-4 + Common files for GLib library ii libglib2.0-dev 2.33.12+really2.32 +.4-5 Development files for the GLib library
      I really would like to understand why I get the warning on this machine but not on the other...

        I really would like to understand why I get the warning on this machine but not on the other...

        The warning (probably harmless) is simple to explain, ExtUtils::Liblist issues it because it doesn't know where to find those libraries (the ....so)

        The error (can't load) is because of those gtk .so's not being found in LD_LIBRARY_PATH or other hardcoded path