Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re: Attempt to reload IO/Socket.pm aborted

by syphilis (Chancellor)
on Nov 02, 2012 at 23:38 UTC ( #1002063=note: print w/replies, xml ) Need Help??


in reply to Attempt to reload IO/Socket.pm aborted

Socket object version 1.94 does not match bootstrap parameter 2.006

You have version 2.006 of Socket.pm, but the Socket "object" (ie Socket.so) is for version 1.94.

This type of error generally indicates that a botched upgrade of Socket (from version 1.94 to 2.006, in this instance) has been performed.
Just how this stuff-up has occurred is anybody's guess.

Removing any existing Socket.so, and then re-installing Socket-2.006 should fix the problem ... but all bets are off if you're running the "system" perl. (Proceed with caution if you *are* using the system's perl.)

Afterthought: Might be safer/easier instead to replace the 2.006 version of Socket.pm with version 1.94. That should work just as well.

Cheers,
Rob
  • Comment on Re: Attempt to reload IO/Socket.pm aborted

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1002063]
help
Chatterbox?
[Corion]: Discipulus: I think Module::Corelist ( or corelist ) can tell you that
[Corion]: Meh - Module::CoreList
[choroba]: Just use List::Util 1.29
[choroba]: Be kind to people using old Perl with newer version of the module
[Corion]: But why not simply specify 'List::Util' => 1.29 in your prerequisites? People might install a more recent version of the module into their Perl
[Corion]: (what choroba said)
[Discipulus]: ah! simpler and cleaner
[Discipulus]: thanks! use List::Util 1.29 qw(pairmap ... just works!
Discipulus is preparing another of his CUFP..

How do I use this? | Other CB clients
Other Users?
Others exploiting the Monastery: (12)
As of 2017-05-25 09:23 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?