Beefy Boxes and Bandwidth Generously Provided by pair Networks
Do you know where your variables are?

Re: Minimum Perl Version standard for CPAN?

by davido (Archbishop)
on Jan 23, 2013 at 23:14 UTC ( #1015043=note: print w/replies, xml ) Need Help??

in reply to Minimum Perl Version standard for CPAN?

Moose and Moo support Perl 5.8, but not 5.6. And we frequently see questions from people stuck with 5.8 on RHEL (and apparently unable/unwilling/forbidden from installing a newer local Perl). But it's quite unusual to find a CPAN tester still smoking distributions on Perl's that precede 5.6. Perl's newest features are fantastic for in-house code, but I believe CPAN code ought to be more portable.

I look at it this way; When I put something up on CPAN it's so that others might get some use out of something that I found to be useful. If I'm going to go to the effort of creating a distribution, I may as well do so for as broad a base as I can. Supporting older Perl versions is sort of like supporting a broad range of OS's. I cannot guess who will be using a module, what OS they'll be using, or what Perl version they will have. If I choose not to support a version or an OS, I am placing a limit on who might be able to use the module. Perhaps that's ok. To the extent that it's practical, I prefer to minimize the requirements placed on the user's Perl environment -- at least the requirements that I'm not able to affect.

One thing I try to do is look at what dependencies I really need, and what requirements they impose as well. If I can't live without Moo, then I'm going to have to give up Perl 5.6, so I may as well code to 5.8+. If I can't reasonably live without a module that requires 5.10, then I may as well code to 5.10+ as well. But what I try not to do is code to 5.10 when all of my dependencies are capable of running under 5.6.

Having said all that, I don't give a second thought to pre-5.6.

One module that I'm involved in currently has dependencies that require 5.8, but I'm in the process of re-working it to use a different dependency so that I can support 5.6 too. (The change in dependencies gets me a few other improvements too, in this case). And this all started with a kind message from someone who has provided useful feedback on some of my other work. In this case the request went something like this: "It would be useful to me if XYZ could support 5.6, and here's what I can do to help in that regard." So there are still those out there who have a need, and some of them are appreciative and willing to extend a helpful hand in recapturing some backward compatibility.


  • Comment on Re: Minimum Perl Version standard for CPAN?

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1015043]
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (7)
As of 2018-03-18 15:57 GMT
Find Nodes?
    Voting Booth?
    When I think of a mole I think of:

    Results (230 votes). Check out past polls.