Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re: URI::Escape::escape_char error when posting to a form inside perl script

by Anonymous Monk
on Jan 31, 2013 at 23:32 UTC ( #1016416=note: print w/ replies, xml ) Need Help??


in reply to URI::Escape::escape_char error when posting to a form inside perl script

In my all night (again) of searching I finally found a workaround that solved my issue since the host admin was of no help. In case, this comes up in the future for anyone..

Thank you monks for your help. I was literally lost for days and dreaming about this crap.

use strict; use LWP::UserAgent; use HTTP::Request::Common; my $data1 = "$something"; my $data2 = "someone@email.com; my $data3 = "something"; my $prepstring = "data1=$data1\&data2=$data2\&data3=$data3"; my $ua = LWP::UserAgent->new(); my $response = $ua->post("$URLtoPostTo", Content => $preppedstring ); # This allows reserved characters such as @$ to pass through URI:Escap +e without issue I guess.


Comment on Re: URI::Escape::escape_char error when posting to a form inside perl script
Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1016416]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others lurking in the Monastery: (13)
As of 2015-07-31 11:59 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (276 votes), past polls