in reply to
Re^3: RFC on how I'm doing when it comes to writing objects?
in thread RFC on how I'm doing when it comes to writing objects?
Since I am using these subroutines to return arrays and hashes, they do not benefit from being made into something which looks like an object. I should rename the module to Twitter::Data, take out all of the $class variables and bless uses, and change the calls to it from Twitter::Objects->subName; to Twitter::Data::subName;. The module will still be useful since I will not have to copy and paste the same arrays and hashes in the thirty-odd scripts I have written using the data. Thank you for helping me see where I went wrong in my thinking.
Have a cookie and a very nice day!