Beefy Boxes and Bandwidth Generously Provided by pair Networks
more useful options
 
PerlMonks  

Re: Could not install modules using cpan..

by Anonymous Monk
on Mar 28, 2013 at 07:37 UTC ( #1025882=note: print w/ replies, xml ) Need Help??


in reply to Could not install modules using cpan..

After you have turned off colorize, try  cpan>look CGI then run  perl Makefile.PL then run  dmake test (or nmake test, whatever your perl is setup to use)

Then copy/paste the output of those two commands and share here


Comment on Re: Could not install modules using cpan..
Select or Download Code
Replies are listed 'Best First'.
Re^2: Could not install modules using cpan..
by Arunkumarpro (Initiate) on Mar 29, 2013 at 10:25 UTC
    C:\strawberry>cpan Games::Cards CPAN: CPAN::SQLite loaded ok (v0.202) CPAN: LWP::UserAgent loaded ok (v6.04) CPAN: Time::HiRes loaded ok (v1.9725) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/01mailrc.txt.gz CPAN: YAML::XS loaded ok (v0.38) Fetching with LWP: http://ppm.activestate.com/CPAN/modules/02packages.details.txt.gz read failed: An existing connection was forcibly closed by the remote +host. at C :\strawberry\perl\vendor\lib/LWP/Protocol/http.pm line 414. at C:\stra +wberry\per l\vendor\lib/LWP/UserAgent.pm line 915. C:\strawberry>cpan Games::Cards CPAN: CPAN::SQLite loaded ok (v0.202) CPAN: LWP::UserAgent loaded ok (v6.04) CPAN: Time::HiRes loaded ok (v1.9725) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/01mailrc.txt.gz CPAN: YAML::XS loaded ok (v0.38) Fetching with LWP: http://ppm.activestate.com/CPAN/modules/02packages.details.txt.gz Fetching with LWP: http://ppm.activestate.com/CPAN/modules/03modlist.data.gz Creating database file ... Done!Running install for module 'Games::Cards' Running make for A/AK/AKARGER/Games-Cards-1.45.tar.gz Fetching with LWP: http://ppm.activestate.com/CPAN/authors/id/A/AK/AKARGER/Games-Cards-1. +45.tar.gz CPAN: Digest::SHA loaded ok (v5.73) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/id/A/AK/AKARGER/CHECKSUMS CPAN: Compress::Zlib loaded ok (v2.055) Checksum for C:\strawberry\cpan\sources\authors\id\A\AK\AKARGER\Games- +Cards-1.45 .tar.gz ok CPAN: Archive::Tar loaded ok (v1.90) CPAN: File::Temp loaded ok (v0.22) CPAN: CPAN::Meta loaded ok (v2.120921) CPAN.pm: Building A/AK/AKARGER/Games-Cards-1.45.tar.gz Checking if your kit is complete... Looks good Writing Makefile for Games::Cards Writing MYMETA.yml and MYMETA.json CPAN: Module::CoreList loaded ok (v2.76) !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! ERROR: Cannot copy 'lib/Games/Cards/images/7h.gif' to 'blib\lib\Games\ +Cards\imag es\7h.gif': No such file or directory !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! at -e line 1. dmake.EXE: Error code 130, while making 'pm_to_blib' AKARGER/Games-Cards-1.45.tar.gz C:\strawberry\c\bin\dmake.EXE -- NOT OK Running make test Can't test without successful make Running make install Make had returned bad status, install seems impossible

      As 7h.gif is contained in Games::Cards at http://cpansearch.perl.org/src/AKARGER/Games-Cards-1.45/lib/Games/Cards/, most likely either the download of Games::Cards failed or your tar program you use for unpacking the distribution is broken.

      Personally, I would now manually try the steps and investigate the intermediate results. The README file details the separate steps to be done after unpacking the distribution. A potential shortcut to downloading and unpacking could be to use the look command of CPAN:

      cpan> look Games::Cards ... Z:\...\Games-Cards-1.45> ... now proceed with installation

      Are you working on Windows or Unix?!

      if you are working on Windows maybe this can help :

      "The reason this is happening is that i set an autorun in my cmd using regedit HKEY->Software->Microsoft->Command processor->autorun to change to my working directory. This makes the dmake program look in the wrong place. After deleting autorun everything worked like a charm."

      This was one of the first hits, when I looked on google for the error code 130..

      maybe you can look deeper into it when you search for the error code yourself

      greetings

        FWIW you can check it with

        reg query "HKCU\Software\Microsoft\Command Processor"

        But that "feature" has got to be one of the dumbest malware/jokes msdn played

        but in my machine i have not set any autorun..i did check it

        Yup!!!that nailed it!! Thanks jerre_111 ... Ofcourse it worked like a charm!!

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1025882]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (3)
As of 2015-08-30 00:12 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The oldest computer book still on my shelves (or on my digital media) is ...













    Results (346 votes), past polls