Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re: Re: Re: Re: Re: Problem with uploading file

by Siddartha (Curate)
on Aug 16, 2001 at 14:36 UTC ( #105324=note: print w/ replies, xml ) Need Help??


in reply to Re: Re: Re: Re: Problem with uploading file
in thread Problem with uploading file

tachyon, thanks a lot for your help

Here is the output:

d_file"; filename="test.txt" Content-Type: application/mac-binhex40 This is a test text file. This time with more data. -----------------------------32052533347522 Content-Disposition: form-data; name="Upload" Upload -----------------------------32052533347522--
The data is there, but the raw data doesn't all seem to be getting through.

It looks like some of the file is being sent, but not the rest of the POST data.

What bothers me mostly is that I don't get the same buffer data displayed every time I run it.
Sometimes all I get is this:
61032563207--

Thanks for all your help so far. I have been trying to debug everything, but don't seem to get anywhere. I used perl -w, but don't get any warnings. I think I'll try and reinstall CGI.pm next.

My form seems to be working like it should. With the default encoding everything goes fine, and is passed like it should. With "multipart/form_data", it seems like the POST data is not all being sent.

Any comments or stuff for me to look at would be appreciated.

-Siddartha


Comment on Re: Re: Re: Re: Re: Problem with uploading file
Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://105324]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others lurking in the Monastery: (17)
As of 2014-07-30 08:40 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (229 votes), past polls