Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: Re: CGI or Apache Problem?

by BigJoe (Curate)
on Jan 19, 2002 at 08:25 UTC ( #140042=note: print w/ replies, xml ) Need Help??


in reply to Re: CGI or Apache Problem?
in thread CGI or Apache Problem?

Yes I am running mod_perl. Do you know if there is something I can set to not allow this?

--BigJoe

Learn patience, you must.
Young PerlMonk, craves Not these things.
Use the source Luke.

Replies are listed 'Best First'.
Re: Re: Re: CGI or Apache Problem?
by perrin (Chancellor) on Jan 19, 2002 at 09:20 UTC
    You can use Apache::PerlRun, which clears globals for you, or you can fix the problem in your script.

    I see at least one possible cause of the problem. Your sub HANDLE_PRODUCTS() is referring to the variable $email_body, which is a lexical declared outside the subroutine. That creates a closure, and this sub keeps a private copy of that variable from then on. The best way to fix this is to pass a reference to $email_body into the subroutine instead.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://140042]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (8)
As of 2016-08-25 12:28 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    The best thing I ever won in a lottery was:















    Results (359 votes). Check out past polls.