Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery

/ troubles

by silent11 (Vicar)
on Oct 20, 2004 at 19:07 UTC ( #400958=monkdiscuss: print w/ replies, xml ) Need Help??

This is the second time this has happened. I hope I can explain myself well enough for those with power to look into the problem.

Basically, it seems that when I am on certain pages the "Perl Monks" link at the top of the page takes me to / which, for me is a "Search Results" page page searching for "".

These are the links I followed to arrive at Search Results when trying to get to The Monastery Gates.

From page Re^4: I prefer to wear... I clicked on the following link, I prefer to wear..., which takes me to the current poll, "I prefer to wear...". From there, when I click "Perl Monks" I am taken to "Search Results" as opposed to The Monastery Gates.

I took a look at the source and found the link to The Monastery Gates constructed like such:
<a class =" titlebar" href ="" > Perl&nbsp;Monks </a>
Could that whitespace in the href be the problem? Is it just me or can any of you recreate this?

Browser: Firefox 1.0

Spread Firefox
Go Astros!

Comment on / troubles
Download Code
Replies are listed 'Best First'.
Re: / troubles (browser bug, fixed?)
by tye (Sage) on Oct 20, 2004 at 20:45 UTC

    The actual source code that is output is:

    <a class = "titlebar" href = "" >

    So what "view source" is telling you

    <a class =" titlebar" href ="" >

    looks like the standard Mozilla-based breakage of munching the source code before it shows it to you in "view source". And it looks like the extra spaces are compressed badly and inconsistently. So I've taken out a ton of whitespace (sorry, Petruchio) and we'll see if the problem recurs.

    - tye        

Re: / troubles
by Golo (Friar) on Oct 20, 2004 at 19:24 UTC
    I could not recreate the problem following your instructions above, but had the same issue a couple of times lately. Unfortunatly I cannot recall what I did before it happened (same browser).

    UPDATE: The problem seems to come from a slash in the url: somehow (right after posting) it became and the relative link to would therefore take me to / IE is doing the same. Maybe a link to "/" would fix this?
Re: / troubles (fixed)
by demerphq (Chancellor) on Oct 26, 2004 at 15:30 UTC

    I bet you posted and previewed before this happened. The preview submit form wasnt playing nice with some other changes we did earlier and was causing this to happen. I patched all of the offending code yesterday so this error should be a thing of the past.


      First they ignore you, then they laugh at you, then they fight you, then you win.
      -- Gandhi


Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: monkdiscuss [id://400958]
Approved by kvale
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (9)
As of 2015-11-25 14:30 GMT
Find Nodes?
    Voting Booth?

    What would be the most significant thing to happen if a rope (or wire) tied the Earth and the Moon together?

    Results (677 votes), past polls