Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number

Re: XML::Atom feed parsing problem

by LTjake (Prior)
on Mar 20, 2007 at 23:38 UTC ( #605767=note: print w/ replies, xml ) Need Help??

in reply to XML::Atom feed parsing problem

I added use LWP::Debug qw(+) to the code to see the network traffic in which i found:

LWP::UserAgent::send_request: GET ... LWP::UserAgent::send_request: GET +eeds/posts/default

So it appears to be getting the feed. I also did a dump of $entries[ 0 ] which gave me:

$VAR1 = bless( { 'ns' => '', 'elem' => bless( do{\(my $o = 140714248)}, 'XML::LibX +ML::Element' ), 'version' => '0.3' }, 'XML::Atom::Entry' ); for me! Sorry.

"Go up to the next female stranger you see and tell her that her "body is a wonderland."
My hypothesis is that she’ll be too busy laughing at you to even bother slapping you.
" (src)

Comment on Re: XML::Atom feed parsing problem
Select or Download Code
Replies are listed 'Best First'.
Re^2: XML::Atom feed parsing problem
by cormanaz (Chaplain) on Mar 24, 2007 at 00:47 UTC
    Hmm...strange. Stranger still, I switched to XML::FeedPP and that works fine. So the practical problem is solved, but I can't explain the original problem!

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://605767]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (11)
As of 2015-10-07 17:53 GMT
Find Nodes?
    Voting Booth?

    Does Humor Belong in Programming?

    Results (194 votes), past polls