Beefy Boxes and Bandwidth Generously Provided by pair Networks
Think about Loose Coupling
 
PerlMonks  

Re: Need help compiling Net::Pcap on Ubuntu 8.04

by pc88mxer (Vicar)
on Jul 21, 2008 at 22:23 UTC ( #699171=note: print w/ replies, xml ) Need Help??


in reply to Need help compiling Net::Pcap on Ubuntu 8.04

Do you really need to recompile it? The package libnet-pcap-perl already contains Net::Pcap.


Comment on Re: Need help compiling Net::Pcap on Ubuntu 8.04
Select or Download Code
Replies are listed 'Best First'.
Re^2: Need help compiling Net::Pcap on Ubuntu 8.04
by bpa (Novice) on Jul 21, 2008 at 22:53 UTC
    Thank you for the reply pc88mxer. It looks like libnet-pcap-perl only has version .04 of Net::Pcap. I need at least version 0.12 because it is a dependency for Net-Write-1.03. When running "perl Makefile.PL" for Net-Write-1.03, I get the following:

    Warning: prerequisite Net::Pcap 0.12 not found. We have 0.04.

Re^2: Need help compiling Net::Pcap on Ubuntu 8.04
by Anonymous Monk on Mar 28, 2010 at 10:58 UTC
    hi all i was trying to install the Net-Libdnet-0.01 fist i download the .gz file uncompress it under root user i make cp /usr/include/dumbnet.h /usr/include/dnet.h just in case then perl Makefile.PL don't make the install here just go to the newly generated Makefile file chmod 777 Makefile vi Makefile change the parameter ldnet to ldumbnet then make make install and it will work

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://699171]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (6)
As of 2015-08-28 10:40 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The oldest computer book still on my shelves (or on my digital media) is ...













    Results (335 votes), past polls