Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: DYNALOAD ISSUE

by samtregar (Abbot)
on Oct 18, 2010 at 16:23 UTC ( #865983=note: print w/ replies, xml ) Need Help??


in reply to DYNALOAD ISSUE

Have you tried rebuilding and reinstalling the P4 module? That's what I'd try.

-sam


Comment on Re: DYNALOAD ISSUE
Replies are listed 'Best First'.
Re^2: DYNALOAD ISSUE
by miked348 (Initiate) on Oct 18, 2010 at 17:41 UTC
    Ran the install script to install P4 again but no change in the error message. I did a nm P4.so | grep <symbol_name> to see it is installed in that shared library off /usr/lib/perl5/site_perl/5.8.8 BUT the P4 and P4.so is NOT found in /usr/lib/perl5/5.8.8/..... I thought this was normal but the error message notes that 'standard' path missing something...and it is to be sure but why? ------mikeD
      Did you just reinstall P4 or did you rebuild it? If you didn't try rebuilding, try that.

      -sam

        Was just now able to return to this issue and removed the P4 entries and did the deploy from scratch again! New copies of P4.so were built and when I run the Perl script i am attempting to use here I fail with the same DynaLoader issue as follows:
        [root@lvmp90154 perl_script]# ./p42svn.pl Can't load '/usr/lib/perl5/s +ite_perl/5.8.8/i386-linux-thread-multi/auto/P4/P4.so' for module P4: +/usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/auto/P4/P4.so: + undefined symbol: _ZTVN10__cxxabiv120__si_class_type_infoE at /usr/l +ib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230. at ./p42svn.pl line 197 Compilation failed in require at ./p42svn.pl line 197. BEGIN failed--compilation aborted at ./p42svn.pl line 197.
        What I do not understand is the symbol is in P4.so as I did a nm P4.so | grep <symbol-name> and its cool!

        This must be some kind of path issue as if I can see it there...it cannot be that but the fact the script cannot see ANY of the symbols in P4.so because it does not know how to get there! But I checked via a env run that my path includes that path!

        Thanks for all you can suggest!

        ------mikeD

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://865983]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others rifling through the Monastery: (14)
As of 2015-07-31 12:03 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (276 votes), past polls