He names the patch files starting with "dor". Would that be a better name than "defined_or"?
I personally prefer "dor" to "defined_or". Actually, I quite like Larry's original "err" -- though the majority of P5P seemed to prefer "dor", based on some long P5P threads. To be "consistent" with Perl 6, you might even consider "orelse".
Note that while the // "defined or" operator was added to Perl 5.10, the low precedence version of this operator was not. AFAICT, this low precedence operator morphed from err to dor to orelse; orelse is in
as a similar, but not identical, low precedence version of //, but it's not in Perl 5 and I'm not aware of any plans to add it. See also this Larry response on perl6-language mailing list.