Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

Re^3: Including dependencies while creating rpm packages of perl modules

by Plankton (Priest)
on Dec 26, 2011 at 18:23 UTC ( #945119=note: print w/ replies, xml ) Need Help??

Comment on Re^3: Including dependencies while creating rpm packages of perl modules
Re^4: Including dependencies while creating rpm packages of perl modules
by sathya_myl (Acolyte) on Dec 28, 2011 at 08:57 UTC

    After installing DBI and Digest::SHA1 i'm able to generate rpm for Apache::DBI. Thanks for the reply.

    But when i'm trying the create rpm for HTTP::Date it dies with following error:

    Unable to build module, the following dependencies have failed:
    perl >= 5.008008

    The installed perl version is 5.10.1. Help me to proceed further.

      How are you trying to create the rpm for HTTP::Date? What command do you execute and what is its output?

        cpan2rpm --debug --no-sign ~/builddir/test/HTTP-Date-6.00.tar.gz

        Unable to build module, the following dependencies have failed:
        perl >= 5.008008
        Stopped at /usr/bin/cpan2rpm line 491.

        Monks, any update for this thread.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://945119]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (12)
As of 2015-07-01 22:01 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (24 votes), past polls