Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

Re^3: SOAP-Lite-0.714 Not working

by Plankton (Vicar)
on Apr 18, 2012 at 05:11 UTC ( #965622=note: print w/replies, xml ) Need Help??


in reply to Re^2: SOAP-Lite-0.714 Not working
in thread SOAP-Lite-0.714 Not working

Well the reason I say install by executing perl -MCPAN -eshell is that CPAN module will download and install any modules SOAP::Lite is dependent upon. Crypt::SSLeay will probably need some encryption software installed that is not available from cpan, but you would get some error message telling you what to do. So really do the perl -MCPAN -eshell thing and let the CPAN module do its thing. It is better than doing wget http://search.cpan.org/CPAN/authors/id/M/MK/MKUTTER/SOAP-Lite-0.714.tar.gz && tar -xzf SOAP-Lite-0.714.tar.gz && cd SOAP-Lite-0.714 && make && make test && make install.

Replies are listed 'Best First'.
Re^4: SOAP-Lite-0.714 Not working
by btechpl (Initiate) on Apr 18, 2012 at 18:23 UTC
    Yes, it does need an encryption software. It requires OI::Socket::SSL. This has been installed, and is recognized by SOAP::Lite. Thanks for reply.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://965622]
help
Chatterbox?
[1nickt]: choroba no kidding! The muscle memory alone makes it insignificant. I suppose the addition of param checking is nice. But if you are using MOo anyway you are using Type::Tiny, and you can easily use T::T for params in regular methods.

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (5)
As of 2017-11-24 13:59 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In order to be able to say "I know Perl", you must have:













    Results (349 votes). Check out past polls.

    Notices?