Beefy Boxes and Bandwidth Generously Provided by pair Networks
The stupid question is the question not asked
 
PerlMonks  

Re^2: Tie::File failing with Unicode/UTF-8 encoding?

by HelenCr (Monk)
on Nov 03, 2012 at 18:46 UTC ( #1002130=note: print w/ replies, xml ) Need Help??


in reply to Re: Tie::File failing with Unicode/UTF-8 encoding?
in thread Tie::File failing with Unicode/UTF-8 encoding?

Kenosis: this is very interesting.

1. Is there a quick way to convert back the PerlMonks output, so that Unicode/UTF8 editors can show it in the original encoding?

2. It seems that in your setup (apparently, the difference is ActivePerl vs. StrawberryPerl/DWIMPerl that I am using), the problem does not occur. Could the cause be the Tie::File code? StrawberryPerl uses $VERSION = "0.97_02"; Which version is ActivePerl using?


Comment on Re^2: Tie::File failing with Unicode/UTF-8 encoding?
Re^3: Tie::File failing with Unicode/UTF-8 encoding?
by Kenosis (Priest) on Nov 03, 2012 at 19:03 UTC
    1. I don't know about these things... Yet...
    2. ActivePerl uses $VERSION = "0.98" for Tie::File. Perhaps upgrading the Module is worth a try (or tie).

      I have updated Tie::File to Version 0.98. It didn't help.

      This is very strange. The problem must be lying somewhere else.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1002130]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (5)
As of 2014-07-23 00:53 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (130 votes), past polls