Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re^2: HTTP error response code 500 using LWP::UserAgent on one site, but not on any other

by ted.byers (Scribe)
on Nov 16, 2012 at 21:23 UTC ( #1004242=note: print w/ replies, xml ) Need Help??


in reply to Re: HTTP error response code 500 using LWP::UserAgent on one site, but not on any other
in thread HTTP error response code 500 using LWP::UserAgent on one site, but not on any other

Thanks

Yes, I have tried using Wireshark in the past. I am sure some find it useful, but I had some trouble getting it's user interface to do anything that was useful for me. Part of the problem is it gets everything; most of which is irrelevant to the problem at hand. It would be more useful if it could be told to get the traffic only between my client script and the server it is trying to connect to.

Thanks again

Ted


Comment on Re^2: HTTP error response code 500 using LWP::UserAgent on one site, but not on any other
Re^3: HTTP error response code 500 using LWP::UserAgent on one site, but not on any other
by aitap (Deacon) on Nov 16, 2012 at 22:23 UTC
    You need to write a filter expression. In your case it should look like http && ip.addr == <server's IP address> (see example).
    Sorry if my advice was wrong.

      Thanks. That looks like it would help. I'll give it a try and report back.

      Thanks

      Ted

      progress of sorts: I have learned, using Wireshark, that the failure happens at the server, in the process of the hand-shaking between client and server involved in the establishment of an SSL connection. My script sends the usual hello message, and normally the other servers I connect to send back their own hello message. This one does not. The diaglog ends with my script sending it's first hello message to the server.

      My challenge right now is two fold. 1) How to get wireshark to dump all the data it has collected (subject to my display filter) to a text file, so that I can send it to the tech guys at the company that owns the server. 2) How to set the level of SSL debugging in the SSL system used by LWP.

      Thanks.

      Ted

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1004242]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others romping around the Monastery: (14)
As of 2014-10-30 17:43 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (208 votes), past polls