Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Need suggestion on option name for upcoming MCE 1.2 release

by marioroy (Sexton)
on Nov 28, 2012 at 03:21 UTC ( #1005954=perlquestion: print w/ replies, xml ) Need Help??
marioroy has asked for the wisdom of the Perl Monks concerning the following question:

Edit: The option name was renamed to "user_tasks". Updated the URL.

Dearest Perl Monks,

A upcoming Many-core Engine for Perl (MCE) release 1.2 is near completion. The release will support tasklets. The question I have is should the new option name stay "tasklets" or be named "sets" or something else?

A Wiki has been created on the upcoming 1.2 release which contains an image of a 64-cores app driven by MCE. Also shown is how one would instantiate MCE which is provided below.

http://code.google.com/p/many-core-engine-perl/wiki/MCE_Tasks

use threads; use threads::shared; use MCE; my $mce = MCE->new( input_data => \@ip_list, chunk_size => 500, tasklets => [{ max_workers => 8, use_threads => 0, user_func => \&pinger },{ max_workers => 48, use_threads => 1, user_func => \&poller },{ max_workers => 8, use_threads => 1, user_func => \&db }] ); $mce->run();

After some thought, I'm thinking that "tasklets" is fitting here? But maybe "sets" is fitting. Yikes, just coming up with the name for the new option is harder than I had imagined.

Thanks, Mario

Comment on Need suggestion on option name for upcoming MCE 1.2 release
Download Code
Re: Need suggestion on option name for upcoming MCE 1.2 release
by Anonymous Monk on Nov 28, 2012 at 09:32 UTC

    I'm leery of new vocabulary, ie tasklets

      I will change the option name. Thank you.

        I settled on "user_tasks" for the new option name.

        Thanks.

Re: Need suggestion on option name for upcoming MCE 1.2 release
by ColonelPanic (Friar) on Nov 28, 2012 at 13:05 UTC

    To me, a "tasklet" sounds like a tiny task or a subpart of a task.

    I am not familiar with MCE, but from the link it appears that this new option is a group of multiple tasks.

    If it doesn't collide with an existing concept in your module, why not just name it "tasks"?

    Or, if tasks is not specific enough, something like "task_set" or "task_group".

    "sets" plural implies multiple groups of things. Do you have multiple groups, or just one group of tasks?



    When's the last time you used duct tape on a duct? --Larry Wall

      The current MCE has these options: user_begin, user_func, user_end. The new option 'user_tasks' seems appropriate.

      Thank you for your suggestions and guidance on the matter.

      The new option takes an array of tasks. One group of tasks.
Re: Need suggestion on option name for upcoming MCE 1.2 release
by Don Coyote (Monk) on Nov 28, 2012 at 13:17 UTC

    'sets' has already connotations and is used widely. 'tasklets' is fairly unique and is probably already commonly used within the working group.

    'user_tasks' does have a sense of ownership about it which is helpful/clear, then again tasklet/s does have a good ring to it.

    post critical suggestion... 'shreds', deriving from 'shared threads' truncated to 'shreads' perhaps, though the latter could indicate code of an undesired nature. The former, well I never put a cpu through a paper shredder but maybe fun to see what happens. And welcome to the shredding renaissance :p

      Thank you.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1005954]
Approved by frozenwithjoy
Front-paged by Arunbear
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others imbibing at the Monastery: (8)
As of 2014-12-18 02:00 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    Is guessing a good strategy for surviving in the IT business?





    Results (41 votes), past polls