Beefy Boxes and Bandwidth Generously Provided by pair Networks Joe
Think about Loose Coupling
 
PerlMonks  

Re^3: Failure, need help : i naively tried to update Strawberry Perl, and broke it

by Anonymous Monk
on Dec 11, 2012 at 08:22 UTC ( #1008234=note: print w/ replies, xml ) Need Help??


in reply to Re^2: Failure, need help : i naively tried to update Strawberry Perl, and broke it
in thread Failure, need help : i tried to update Strawberry Perl naively, and broke it

I rebooted already, so i guess my only option is to uninstall and re-install. I'd like not to have to re-install all the CPAN modules that i have, if possible.

You would have to do that anyway going from 5.12 to 5.16


Comment on Re^3: Failure, need help : i naively tried to update Strawberry Perl, and broke it
Re^4: Failure, need help : i naively tried to update Strawberry Perl, and broke it
by mascip (Pilgrim) on Dec 11, 2012 at 08:25 UTC

    Oh, ok. I didn't know this. Ouch.
    Thank you for the information.

Re^4: Failure, need help : i naively tried to update Strawberry Perl, and broke it
by mascip (Pilgrim) on Dec 11, 2012 at 08:56 UTC

    I might try something even sillier than what i did before (well, things cannot get more broken than they are already, so...) :
    installing v5.12 again, now.
    Hopefully, things will work again and then i can get perlall (and maybe Pinto), and do things properly.

    How does it sound ?

      How does it sound ?

      Sounds like work :) esp for windows ;)(even if you aren't solo I would use cava, maybe even with citrus) but it might work, I wish you luck, the matrix doesn't :(

        "Citrus Perl can re-package itself as a new distribution including your own modules."
        Wow, this sounds tasty.

        "Cava Packager allows packaging of applications written in Perl. Packaged applications can be distributed without the need for an installation of Perl on the target machine."
        Is this "a bit similar" to having a CPAN mirror on my computer?

        Is it possible, with perlall, to have different version on Perl installed ? Like a Strawberry v5.12, and a Citrus v5.16 ?

        PS : i'm going out for two or three hours, will try to re-install v5.12.3 when i'm back.

        I got this answer from the Strawberry people :

        Unfortunately v5.12.3 doesn't handle properly upgrade so your troubles are probably due to the mix of 5.12 and 5.16 dlls which do not play well together.
        Try to
        1/ uninstall strawberry
        2/ manually delete c:\strawberry (or what was your install directory)
        3/ make clean install using 5.16 MSI

        I have done what i said before, instead : uninstalled Perl, then installed v5.12.3 (the one i initially had). Everything seems to work alright, but i have to re-download and install all the CPAN modules that i use...

        After that, i will try and use Pinto.
        And after that, i will try and use perlall to upgrade to v5.16. What i don't know is whether i can use it to install a v5.16 Citrus Perl, along with Strawberry v5.12. It doesn't sound right to me, for some reason. I might as well start from scratch with Citrus v5.16, and hope that my code is Citrus v5.16 compatible.
        I'm lucky to have this problem while my code base is still small.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1008234]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (8)
As of 2014-04-16 06:06 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (414 votes), past polls