Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re: MExtUtuils result in error while trying to install modules.

by Anonymous Monk
on Feb 06, 2013 at 14:01 UTC ( #1017438=note: print w/ replies, xml ) Need Help??


in reply to MExtUtuils result in error while trying to install modules.

Anybody knows what the h.. can be wrong?

:) You're not providing actionable details, but, its probably dll hell of some sort

You can alway try rebooting :)


Comment on Re: MExtUtuils result in error while trying to install modules.
Replies are listed 'Best First'.
Re^2: MExtUtuils result in error while trying to install modules.
by abt (Novice) on Feb 06, 2013 at 14:35 UTC
    t/zz_distrib.t ........ skipped: Author tests Test Summary Report ------------------- t/01_load.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: Bad plan. You planned 6 tests but ran 0. t/02_inheritance.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/03_event.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/04_userdata.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/05_timer.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/06_loadxpm.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/07_overload.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/08_ovl_func.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/09_create_delete.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/10_oor.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/11_twostage.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/13_nbksizer.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/14_eh_die.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/15_threads.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/16_stream.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/17_thread_evt.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/18_unicode.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/19_overlay.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/20_ctx_threads.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/21_locale.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output t/22_interface.t (Wstat: 9728 Tests: 0 Failed: 0) Non-zero exit status: 38 Parse errors: No plan found in TAP output Files=23, Tests=0, 12 wallclock secs ( 0.13 usr + 0.06 sys = 0.19 Result: FAIL Failed 21/23 test programs. 0/0 subtests failed. dmake.exe: Error code 255, while making 'test_dynamic' MDOOTSON/Wx-0.9916.tar.gz C:\strawberry\c\bin\dmake.exe test -- NOT OK //hint// to see the cpan-testers results for installing this module reports MDOOTSON/Wx-0.9916.tar.gz Running make install make test had returned bad status, won't install without force Stopping: 'install' failed for 'M/MD/MDOOTSON/Wx-0.9916.tar.gz'.
      Try running perl -Mblib t/01_load.t
      That should cause the same crash - but, if you're lucky, you might also get a meaningful error message.

      Cheers,
      Rob

        1..6 on command line. Followed by same crash as you expected.

      :) sorry, that is of no use
Re^2: MExtUtuils result in error while trying to install modules.
by abt (Novice) on Feb 06, 2013 at 14:16 UTC

    rebooting didnt help. ;) what additional information do you like? tried installing manually, via cpan, ppm.

      rebooting didnt help. ;) what additional information do you like? tried installing manually, via cpan, ppm.

      any kind of information , but details, not summaries

      anything that would help someone reproduce the problem

      for example, figure out which test causes perl.exe stopped working,
      what modules and dlls it loads Devel::VersionDump, %::
      figure out which line in the test causes it (Devel::Trace),
      attach a debugger figure out which dll's are loaded at the time,
      figure a way to get more error data from windows that the generic message -- eventvwr? windbg? depends? something something
      don't forget to rule out resource limits if you know how, and ... stuff like that

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1017438]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (13)
As of 2015-07-30 13:54 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (271 votes), past polls