Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re^2: Print to Browser Headers Not Working

by Loops303 (Novice)
on Feb 27, 2013 at 17:12 UTC ( #1020928=note: print w/ replies, xml ) Need Help??


in reply to Re: Print to Browser Headers Not Working
in thread Print to Browser Headers Not Working

I'm a newb so please forgive me. I'm running the apache server that comes with OS X.

Since I posted this question, I found a PHP script that does a download (example that comes with files, etc.) and it worked through the browser. It seems that perl is at issue, and all the headers are just not working.

And I tried the content disposition and content type together, and individually, and the same result happens: it prints the output to the browser.

Any tips on how to configure the server?

Thank you.


Comment on Re^2: Print to Browser Headers Not Working
Re^3: Print to Browser Headers Not Working
by Your Mother (Canon) on Feb 27, 2013 at 17:22 UTC

    What aitap said sounds like it might be right to me. Webservers can be (Apache often is?) set up to send their own headers and since headers can only go once your CGI headers are printed as content.

Re^3: Print to Browser Headers Not Working
by aitap (Deacon) on Feb 27, 2013 at 17:45 UTC

      Thanks Everyone! The links you sent helped me figure it out --- needed to add

      PerlSendHeader On

      To the .conf file

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1020928]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others musing on the Monastery: (5)
As of 2014-11-26 04:45 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My preferred Perl binaries come from:














    Results (162 votes), past polls