Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re^3: PAR: pp No Perl script found in input (upgrade)

by Anonymous Monk
on Feb 28, 2013 at 05:29 UTC ( #1020996=note: print w/ replies, xml ) Need Help??


in reply to Re^2: PAR: pp No Perl script found in input (upgrade)
in thread PAR: pp No Perl script found in input

Since pp actually works if I use it in \Perl\site\bin I doubt it an installation issue unless some PATH did not get updated somehow.

You can doubt it, but I am telling you, your installation is messed up


Comment on Re^3: PAR: pp No Perl script found in input (upgrade)
Re^4: PAR: pp No Perl script found in input (upgrade)
by mkmal (Novice) on Feb 28, 2013 at 19:23 UTC
    OK, attempted to re-install, cpan says all is well and I still have the same problem, now what?

    cpan install pp
    Set up gcc environment - 3.4.5 (mingw-vista special r3)
    CPAN: Term::ANSIColor loaded ok (v3.02)
    CPAN: Storable loaded ok (v2.34)
    Reading 'C:\Perl\cpan\Metadata'
    Database was generated on Wed, 27 Feb 2013 12:08:03 GMT
    CPAN: Module::CoreList loaded ok (v2.77)
    pp is up to date (0.992).

    pp -o hello.exe hello.pl
    No Perl script found in input

    pp still works fine if I move the Perl script into \Perl\site\lib and run the command from there.
      cpan> force install pp
        OK, I ran it with force and it re-installed with no errors. I still have the same exact issue.
        any ideas?

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1020996]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (11)
As of 2014-08-01 16:09 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    Who would be the most fun to work for?















    Results (28 votes), past polls