Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: problem with getting web source

by Corion (Pope)
on Mar 24, 2013 at 17:04 UTC ( #1025163=note: print w/ replies, xml ) Need Help??


in reply to problem with getting web source

How does it fail for you?

Does the URL work from the browser?

Have you tried error diagnosis by switching from LWP::Simple to LWP::UserAgent and looking at the error returned?


Comment on Re: problem with getting web source
Re^2: problem with getting web source
by WojciechGajewski (Initiate) on Mar 24, 2013 at 17:08 UTC
    Yes, it works fine from the browser. You can check it yourself. Just click the gutenberg link. The failure means instead of the source page I am getting an empty string.

      Just because it works for me, from my browser, does not mean that it will work for you, from your browser.

      I suggest you now use LWP::UserAgent to do the URL downloading. That way, you get more detailed error information instead of just a pass/fail status.

        Exactly! I had to use some useragent. the default get method apparently doesnt use any and hence I couldnt download the source! Thanks! Problem solved!

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1025163]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others having an uproarious good time at the Monastery: (8)
As of 2014-10-23 00:17 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (122 votes), past polls