Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Could not install modules using cpan..

by Arunkumarpro (Initiate)
on Mar 28, 2013 at 06:42 UTC ( #1025866=perlquestion: print w/ replies, xml ) Need Help??
Arunkumarpro has asked for the wisdom of the Perl Monks concerning the following question:

am getting some problems with the DMAKE command...I modified makepl_arg to use dmake instead of make..still i have some problem..this is ma cpan config info

cpan> o conf [32m$CPAN::Config options from C:\Users\Arun\AppData\Local/.cpan/CPA +N/MyConfig. pm:[0m [32m commit [Commit changes to disk][0m [32m defaults [Reload defaults from disk][0m [32m help [Short help about 'o conf' usage][0m [32m init [Interactive setting of all options][0m [32m[0m [32m applypatch undef[0m [32m auto_commit [1][0m [32m build_cache [10][0m [32m build_dir [C:\Perl64/cpan/build][0m [32m build_dir_reuse undef[0m [32m build_requires_install_policy undef[0m [32m bzip2 undef[0m [32m cache_metadata [1][0m [32m check_sigs undef[0m [32m colorize_debug undef[0m [32m colorize_output [1][0m [32m colorize_print [green][0m [32m colorize_warn [red][0m [32m commandnumber_in_prompt undef[0m [32m commands_quote undef[0m [32m connect_to_internet_ok undef[0m [32m cpan_home [C:\Perl64/cpan][0m [32m curl undef[0m [32m dontload_hash undef[0m [32m dontload_list undef[0m [32m ftp [][0m [32m ftp_passive undef[0m [32m ftp_proxy [][0m [32m ftpstats_period undef[0m [32m ftpstats_size undef[0m [32m getcwd [][0m [32m gpg [][0m [32m gzip [][0m [32m halt_on_failure undef[0m [32m histfile [C:\Perl64/cpan/histfile][0m [32m histsize [100][0m [32m http_proxy [][0m [32m inactivity_timeout [0][0m [32m index_expire [1][0m [32m inhibit_startup_message [0][0m [32m keep_source_where [C:\Perl64/cpan/sources][0m [32m load_module_verbosity [none][0m [32m lynx [][0m [32m make [C:\Perl64\bin\dmake.exe][0m [32m make_arg [][0m [32m make_install_arg [UNINST=1][0m [32m make_install_make_command undef[0m [32m makepl_arg [make=dmake][0m [32m mbuild_arg [][0m [32m mbuild_install_arg [--uninst=1][0m [32m mbuild_install_build_command undef[0m [32m mbuildpl_arg [][0m [32m ncftp undef[0m [32m ncftpget undef[0m [32m no_proxy [][0m [32m pager [more][0m [32m password undef[0m [32m patch undef[0m [32m patches_dir undef[0m [32m perl5lib_verbosity undef[0m [32m prefer_external_tar undef[0m [32m prefer_installer undef[0m [32m prefs_dir undef[0m [32m prerequisites_policy [follow][0m [32m proxy_pass undef[0m [32m proxy_user undef[0m [32m randomize_urllist undef[0m [32m scan_cache [atstart][0m [32m shell [C:\Windows\system32\cmd.exe][0m [32m show_unparsable_versions undef[0m [32m show_upload_date undef[0m [32m show_zero_versions undef[0m [32m tar [][0m [32m tar_verbosity undef[0m [32m term_is_latin [1][0m [32m term_ornaments undef[0m [32m test_report undef[0m [32m trust_test_report_history undef[0m [32m unzip [][0m [32m urllist 0 [http://ppm.activestate.com/CPAN] 1 [http://cpan.perl.org][0m [32m use_sqlite undef[0m [32m username undef[0m [32m version_timeout undef[0m [32m wait_list undef[0m [32m wget [][0m [32m yaml_load_code undef[0m [32m yaml_module [YAML::XS][0m [32m[0m [32m[0m cpan>

when i tried to install any modules , i got the following errors...

cpan> install "GDBM_File" [32mReading 'C:\Perl64\cpan\Metadata'[0m [32m Database was generated on Wed, 27 Mar 2013 10:17:02 GMT[0m [32mRunning install for module 'GDBM_File'[0m [31mThe most recent version "1.14" of the module "GDBM_File" is part of the perl-5.17.4 distribution. To install that, you need to +run force install GDBM_File --or-- install F/FL/FLORA/perl-5.17.4.tar.bz2[0m [32mRunning make test[0m [32m Can't test without successful make[0m [32mRunning make install[0m [32m Make had returned bad status, install seems impossible[0m [32mFailed during this command: FLORA/perl-5.17.4.tar.bz2 : make NO isa perl[0m [32m[0m cpan>

Comment on Could not install modules using cpan..
Select or Download Code
Re: Could not install modules using cpan.. (GDBM_File)
by Anonymous Monk on Mar 28, 2013 at 06:50 UTC

    GDBM_File is not a module you can install using cpan, see Re^9: GDBM_File for Windows?

    Also, I don't know what those funny characters are that you show, but try using  set TERM=dumb or remove that colorize option from your cpan configuration, because you're getting funny chars instead of colors

      I could not install any modules using cpan

        I could not install any modules using cpan

        And then what happened?

Re: Could not install modules using cpan..
by Anonymous Monk on Mar 28, 2013 at 06:56 UTC

      i could not install any modules using cpan...not only GDBM

        i could not install any modules using cpan...not only GDBM

        Thanks, that was clear from your original posting

Re: Could not install modules using cpan..
by Anonymous Monk on Mar 28, 2013 at 07:37 UTC
    After you have turned off colorize, try  cpan>look CGI then run  perl Makefile.PL then run  dmake test (or nmake test, whatever your perl is setup to use)

    Then copy/paste the output of those two commands and share here

      C:\strawberry>cpan Games::Cards CPAN: CPAN::SQLite loaded ok (v0.202) CPAN: LWP::UserAgent loaded ok (v6.04) CPAN: Time::HiRes loaded ok (v1.9725) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/01mailrc.txt.gz CPAN: YAML::XS loaded ok (v0.38) Fetching with LWP: http://ppm.activestate.com/CPAN/modules/02packages.details.txt.gz read failed: An existing connection was forcibly closed by the remote +host. at C :\strawberry\perl\vendor\lib/LWP/Protocol/http.pm line 414. at C:\stra +wberry\per l\vendor\lib/LWP/UserAgent.pm line 915. C:\strawberry>cpan Games::Cards CPAN: CPAN::SQLite loaded ok (v0.202) CPAN: LWP::UserAgent loaded ok (v6.04) CPAN: Time::HiRes loaded ok (v1.9725) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/01mailrc.txt.gz CPAN: YAML::XS loaded ok (v0.38) Fetching with LWP: http://ppm.activestate.com/CPAN/modules/02packages.details.txt.gz Fetching with LWP: http://ppm.activestate.com/CPAN/modules/03modlist.data.gz Creating database file ... Done!Running install for module 'Games::Cards' Running make for A/AK/AKARGER/Games-Cards-1.45.tar.gz Fetching with LWP: http://ppm.activestate.com/CPAN/authors/id/A/AK/AKARGER/Games-Cards-1. +45.tar.gz CPAN: Digest::SHA loaded ok (v5.73) Fetching with LWP: http://ppm.activestate.com/CPAN/authors/id/A/AK/AKARGER/CHECKSUMS CPAN: Compress::Zlib loaded ok (v2.055) Checksum for C:\strawberry\cpan\sources\authors\id\A\AK\AKARGER\Games- +Cards-1.45 .tar.gz ok CPAN: Archive::Tar loaded ok (v1.90) CPAN: File::Temp loaded ok (v0.22) CPAN: CPAN::Meta loaded ok (v2.120921) CPAN.pm: Building A/AK/AKARGER/Games-Cards-1.45.tar.gz Checking if your kit is complete... Looks good Writing Makefile for Games::Cards Writing MYMETA.yml and MYMETA.json CPAN: Module::CoreList loaded ok (v2.76) !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! ERROR: Cannot copy 'lib/Games/Cards/images/7h.gif' to 'blib\lib\Games\ +Cards\imag es\7h.gif': No such file or directory !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! at -e line 1. dmake.EXE: Error code 130, while making 'pm_to_blib' AKARGER/Games-Cards-1.45.tar.gz C:\strawberry\c\bin\dmake.EXE -- NOT OK Running make test Can't test without successful make Running make install Make had returned bad status, install seems impossible

        As 7h.gif is contained in Games::Cards at http://cpansearch.perl.org/src/AKARGER/Games-Cards-1.45/lib/Games/Cards/, most likely either the download of Games::Cards failed or your tar program you use for unpacking the distribution is broken.

        Personally, I would now manually try the steps and investigate the intermediate results. The README file details the separate steps to be done after unpacking the distribution. A potential shortcut to downloading and unpacking could be to use the look command of CPAN:

        cpan> look Games::Cards ... Z:\...\Games-Cards-1.45> ... now proceed with installation

        Are you working on Windows or Unix?!

        if you are working on Windows maybe this can help :

        "The reason this is happening is that i set an autorun in my cmd using regedit HKEY->Software->Microsoft->Command processor->autorun to change to my working directory. This makes the dmake program look in the wrong place. After deleting autorun everything worked like a charm."

        This was one of the first hits, when I looked on google for the error code 130..

        maybe you can look deeper into it when you search for the error code yourself

        greetings

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1025866]
Approved by vinoth.ree
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others studying the Monastery: (13)
As of 2014-07-23 06:14 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (133 votes), past polls