Just one friendly piece of advice: Please stick to one convention when using variable names. You have some variables with like $Summary (a convention no one uses), some like $fulllookupKey (which should really have been $fullLookupKey) and I also saw something like $load_data in one of your post.
Sticking to one convention helps you more than anyone else. You don't need to keep going back to check how you spelled that variable.
in reply to Hashes of Hash in perl
in thread Perl Hash