Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl: the Markov chain saw
 
PerlMonks  

perl version and cpan module

by Thai Heng (Beadle)
on Jun 07, 2013 at 00:27 UTC ( #1037535=perlquestion: print w/ replies, xml ) Need Help??
Thai Heng has asked for the wisdom of the Perl Monks concerning the following question:

The ubuntu install perl 5.14.2 default, and I reinstall perl 5.18 in another directory.

According the monks' reply, I change $Path and can run perl 5.18 in command line. And another question coming: DBIx::Class::Schema cpan module can't works. my questions are

1. Is cpan modulers depending on the perl version? and I must reinstall cpan modulers using perl 5.18?

2. Catalyst.pl use '#!/usr/bin/perl', and Can this change to new perl 5.18.0

thanks a lot.

Comment on perl version and cpan module
Re: perl version and cpan module
by Anonymous Monk on Jun 07, 2013 at 00:29 UTC
    1) yes 2) yes, if you use the new perl to install catalyst, the shebang should be rewritten automagically, but you have to add the directory where catalyst.pl lives into $PATH also, same as you did for your localperl

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1037535]
Approved by kevbot
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (9)
As of 2014-08-27 10:10 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (236 votes), past polls