Beefy Boxes and Bandwidth Generously Provided by pair Networks
We don't bite newbies here... much
 
PerlMonks  

I wonder if there are any supported distro with 5.8.8 perl (not 5.8.9)?

by vsespb (Hermit)
on Jul 15, 2013 at 12:20 UTC ( #1044365=perlquestion: print w/ replies, xml ) Need Help??
vsespb has asked for the wisdom of the Perl Monks concerning the following question:

I found this code
my $str ="OK file1\nline2"; print "OK1\n" if $str =~ qr/^OK file1$/m; print "OK2\n" if $str =~ /^OK file1$/m;
works differently in 5.8.8 and 5.8.9 (5.8.8 prints only OK2)

And I was about to drop 5.8.8 support in my script. I am wondering is there any supported distribution which ships 5.8.8 (not 5.8.9).

I know RHEL supports 5.8.9 till Y2017

But what about 5.8.8?

related topic: What is a really old version of Perl?

UPD: RHEL still supports 5.8.8

UPD2: This code works right on CentOS's perl 5.8.8, but fails under perl5.8.8 on my box (perlbrew) and in this report http://www.cpantesters.org/cpan/report/91d36572-eac6-11e2-90a1-fb47fbca4e08

Comment on I wonder if there are any supported distro with 5.8.8 perl (not 5.8.9)?
Download Code
Re: I wonder if there are any supported distro with 5.8.8 perl (not 5.8.9)?
by hippo (Curate) on Jul 15, 2013 at 13:01 UTC
    I know RHEL supports 5.8.9 till Y2017

    How interesting. All my RHEL5 boxes use 5.8.8. Are you sure about your assertion there?

      You are right. I was sure they upgraded to 5.8.9 this year (as part of CentOS 5.9 release), but now I see it still contain 5.8.8

      Also, the code I posted in first post works right on CentOS (and fails in perlbrew perl)
Re: I wonder if there are any supported distro with 5.8.8 perl (not 5.8.9)?
by rjt (Deacon) on Jul 15, 2013 at 13:03 UTC
    I am wondering is there any supported distribution which ships 5.8.8 (not 5.8.9).

    Not that I could find, but that doesn't mean such a distro doesn't exist. I'm sorry I don't have a more specific answer for you. To find this out, one would have to look at every distribution out there1, and find out which releases are still in support (or which might even have paid vendor support available, which isn't always obvious), and then find out which Perl is packaged with that release, which may or may not be (easily) discernible without actually installing the distribution.

    Personally, I don't go out of my way to support anything older than 5.10 for new code. I don't go out of my way to break it, either, but if it fails the tests on older Perls and the fix is sufficiently ugly, I just bump use 5.0xx and MIN_PERL_VERSION accordingly and move on.

    ___________
    1. Are we limited to Linux? Because I have a mechanical switch on my garage door hooked up to a PPC dev board running an older, still supported, commercial BSD release with Perl 5.6, and there's not enough room on flash to install anything newer.

      I don't go out of my way to support anything older than 5.10 for new code. I don't go out of my way to break it, either
      Interesting strategy. And what if you see than you can use "defined or" in code? Do you use it (immediately breaking 5.8.x) or avoid it?

        I use it. In my case, today, 5.10 is where the cost/benefit ratio starts dipping South of 1.0, so I don't lose much sleep if 5.8.x breaks. Your line in the sand may well be different, and no doubt with good reason.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1044365]
Approved by hdb
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others imbibing at the Monastery: (6)
As of 2014-09-19 10:49 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (135 votes), past polls