Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

installing Net::SSH::Perl on ubuntu

by varalaxmibbnl (Acolyte)
on Sep 18, 2013 at 14:01 UTC ( #1054664=perlquestion: print w/ replies, xml ) Need Help??
varalaxmibbnl has asked for the wisdom of the Perl Monks concerning the following question:

hi monks... please help me how to install Net::SSH::Perl on ubuntu... i don't have that(Net::SSH::Perl) package too in my system... thanx in advance...

Comment on installing Net::SSH::Perl on ubuntu
Re: installing Net::SSH::Perl on ubuntu
by Anonymous Monk on Sep 18, 2013 at 14:02 UTC
    Same as any module (if it works) cpan Net::SSH::Perl
      thanks for reply...i tried with cpan but its not working

        i tried with cpan but its not working

        Well, Cpan/cpan is working for me.

        What exactly happened when you tried?

        What did you try and how?

        Cheers, Sören

        Créateur des bugs mobiles - let loose once, run everywhere.
        (hooked on the Perl Programming language)

Re: installing Net::SSH::Perl on ubuntu
by Corion (Pope) on Sep 18, 2013 at 14:02 UTC
      sorry i don't understand what steps you are talking about...

        Please read the linked node: Re^3: ssh with perl. It says:

        To confirm this, please provide the full output of that cpanm command.

        What part of this is problematic?

Re: installing Net::SSH::Perl on ubuntu
by jellisii2 (Friar) on Sep 18, 2013 at 16:57 UTC
    apt-cache search libnet-ssh lists the following:
    libnet-ssh-gateway-ruby - Transitional package for ruby-net-ssh-gatewa +y libnet-ssh-gateway-ruby1.8 - Transitional package for ruby-net-ssh-gat +eway libnet-ssh-gateway-ruby1.9.1 - Transitional package for ruby-net-ssh-g +ateway libnet-ssh-multi-ruby - Transitional package for ruby-net-ssh-multi libnet-ssh-multi-ruby1.8 - Transitional package for ruby-net-ssh-multi libnet-ssh-multi-ruby1.9.1 - Transitional package for ruby-net-ssh-mul +ti libnet-ssh-perl - Perl extension for secure shell libnet-ssh-ruby1.8 - Transitional package for ruby-net-ssh libnet-ssh2-perl - Perl module for the SSH 2 protocol libnet-ssh2-ruby - Transitional package for ruby-net-ssh libnet-ssh2-ruby1.8 - Transitional package for ruby-net-ssh libnet-ssh2-ruby1.9.1 - Transitional package for ruby-net-ssh ruby-net-ssh - Ruby implementation of the SSH protocol ruby-net-ssh-gateway - Ruby library for tunneling connections to serve +rs with ssh ruby-net-ssh-multi - Ruby library for making multiple SSH connections +to remote systems
    sooo... the easy way to do this is sudo apt-get install libnet-ssh-perl, unless the packaged version is too far behind for you.
      libnet-ssh-perl does not contain Net::SSH::Perl as requested by the OP but Net::SSH!

      $ dpkg --listfiles libnet-ssh-perl /. /usr /usr/share /usr/share/doc /usr/share/doc/libnet-ssh-perl /usr/share/doc/libnet-ssh-perl/copyright /usr/share/doc/libnet-ssh-perl/changelog.Debian.gz /usr/share/man /usr/share/man/man3 /usr/share/man/man3/Net::SSH.3pm.gz /usr/share/perl5 /usr/share/perl5/Net /usr/share/perl5/Net/SSH.pm

      AFAIK, Debian (and so, Ubuntu) does not have a package for Net::SSH::Perl (what would be libnet-ssh-perl-perl) because the module requires libpari (via Math::Pari) which has a license that's not acceptable for Debian.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1054664]
Approved by ww
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (8)
As of 2014-11-25 23:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My preferred Perl binaries come from:














    Results (160 votes), past polls