Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Puzzling error when using ActivePerl.

by Anonymous Monk
on Sep 28, 2013 at 23:47 UTC ( #1056172=perlquestion: print w/ replies, xml ) Need Help??
Anonymous Monk has asked for the wisdom of the Perl Monks concerning the following question:

Hi Monks, I recently updated to ActivePerl 5.18.1 (build 1800) and installing packages seems to be impossible for some reason:
C:\>ppm search dbi Downloading ActiveState Package Repository packlist...not found *** no packages matching 'dbi' found *** C:\>
This occurs regardless of what package I'm looking for. Any ideas how I could resolve this dilemma? When I use the ppm GUI, I cannot list available, i.e., currently uninstalled, packages either.

Thanks.

Comment on Puzzling error when using ActivePerl.
Download Code
Re: Puzzling error when using ActivePerl.
by wjw (Deacon) on Sep 29, 2013 at 00:18 UTC
    I wonder if there might be some config left from previous install, such as ppm source and local ppm db.

    Been a long time since I have used ActiveState... Just a thought...

    guess I would check ActivePerl 5.18 Documentation -> Setup if you have not done so already.

    A bit more info would help too. What OS? 32/64 bit? Update from version?

    Hope that is helpful...

    • ...the majority is always wrong, and always the last to know about it...
    • ..by my will, and by will alone.. I set my mind in motion
Re: Puzzling error when using ActivePerl. (no ppm packages found)
by Anonymous Monk on Sep 29, 2013 at 00:19 UTC
Re: Puzzling error when using ActivePerl.
by Old_Gray_Bear (Bishop) on Sep 29, 2013 at 00:22 UTC
    With out knowing more about how you updated to AP 5.18.1, I'd be suspicious about the missing packing list. A quick Google Search ("ActiveState 5.18.1 packlist") turns up hits from July and September on this year; it looks like there are problems with Cygwin and Debian not installing .packlist files supplied by vendors. (bug 195562, and others)

    You might try installing a fresh copy of the ActivePerl, downloaded directly from the ActiveState site, in a separate location and take a look for the .packlist file(s), and compare that with what exists in your updated directories.

    I suppose that scrubbing your current AP installation and starting from a fresh download is out of the question. (I'm sorry that I can't be more helpful, my "most current" ActivePerl is version 1601, and it finds the packlist just fine.)

    ----
    I Go Back to Sleep, Now.

    OGB

      nah, nothing about that, there is no repository, there is no repository packlist for a nonexistent repository to provide list of packages available to install :)
Re: Puzzling error when using ActivePerl. (no 5.18.1 ppm repositories exist
by Anonymous Monk on Sep 29, 2013 at 00:22 UTC
      The 5.18 repository should be OK. You only have to change to a "newer" repository when changing to a new major version of Perl.

      CountZero

      A program should be light and agile, its subroutines connected like a string of pearls. The spirit and intent of the program should be retained throughout. There should be neither too little or too much, neither needless loops nor useless variables, neither lack of structure nor overwhelming rigidity." - The Tao of Programming, 4.1 - Geoffrey James

      My blog: Imperial Deltronics

        The problem is that the install presets the repository to http://ppm4.activestate.com/MSWin32-x64/5.18/1800/package.xml, but that does not exist.

        And according to this page(scroll to bottom), there are currently no repositories available for 5.18.anything on any platform.


        With the rise and rise of 'Social' network sites: 'Computers are making people easier to use everyday'
        Examine what is said, not who speaks -- Silence betokens consent -- Love the truth but pardon error.
        "Science is about questioning the status quo. Questioning authority".
        In the absence of evidence, opinion is indistinguishable from prejudice.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1056172]
Approved by Old_Gray_Bear
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (6)
As of 2014-07-13 01:39 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    When choosing user names for websites, I prefer to use:








    Results (244 votes), past polls