Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re: Strange problem with Config::General

by Eily (Priest)
on Nov 18, 2013 at 15:20 UTC ( #1063119=note: print w/ replies, xml ) Need Help??


in reply to Strange problem with Config::General

Are you running the exact same code in both cases?. Your output looks like you called $conf->getall in scalar context before assigning the result to %config. Something roughly like : my %config = scalar $cong->getall;, except the problem is probably far less obvious. But then you should have two warnings if they are on:

Odd number of elements in hash assignment at - line X. Use of uninitialized value in print at - line X.

Replies are listed 'Best First'.
Re^2: Strange problem with Config::General
by OfficeLinebacker (Chaplain) on Nov 18, 2013 at 16:04 UTC
    Hi. Yes I have warnings on and the code is identical. Thanks.

      With warnings activated there should have been at least the second one(and I don't see how the first could have been skipped). Are there other warnings you did not see or forgot to tell us about?

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1063119]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others exploiting the Monastery: (6)
As of 2016-08-27 23:06 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    The best thing I ever won in a lottery was:















    Results (389 votes). Check out past polls.