http://www.perlmonks.org?node_id=1063219


in reply to Can you make it nicer?

Personally i consider it most important to have readable code. It doesn't need to be fancy, but it should be quick to be understood. Sometimes i would rather write 2 or 3 lines more, if it would improve readability.
Keeping the same output format of id2path, i would potentially have written it like this:
sub id2path_new { my ($id) = @_; return '' unless $id; my $path = ''; if ($id >= 1_000_000) { $path = sprintf("%09d", $id); $path =~ s#\A(.*)(...)(...)\z#$1/$2/$3#; } else { $path = sprintf("%06d", $id); $path =~ s#\A(..)(..)(..)\z#$1/$2/$3#; } return $path; }
Note: I know that i could also write the regex using \d and the {3} quantifier, resulting in:
\A(\d*)(\d{3})(\d{3})\z
In this case however, i consider the dots to be visually clearer, while having the same effect. Having two hard coded printfs is in my opinion also easier to read than first programmatically creating the sprintf format string.