Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation
 
PerlMonks  

taint-mode failures only on Perl 5.12 and lower?

by einhverfr (Friar)
on Mar 24, 2014 at 11:49 UTC ( #1079510=perlquestion: print w/ replies, xml ) Need Help??
einhverfr has asked for the wisdom of the Perl Monks concerning the following question:

Fellow monks;

I am not quite sure what to do here, but I released a new version of LaTeX::Encode and I started getting cpantesters failures. All failures occur on Perl 5.12 and below, and they are all taint-mode failures. Perl 5.14 and higher work fine.

The stack trace looks like this:

Insecure dependency in require while running with -T switch at /home/s +and/src/perl/repoperls/installed-perls/perl/perl-5.8.9/5da8/lib/5.8.9 +/Test/Builder.pm line 1526. Test::Builder::_try(Test::Builder=HASH(0x22b5120), CODE(0x2250790) +, "die_on_fail", 1) called at /home/sand/src/perl/repoperls/installed +-perls/perl/perl-5.8.9/5da8/lib/5.8.9/Test/Builder.pm line 914 Test::Builder::_unoverload(Test::Builder=HASH(0x22b5120), "\"\"", +SCALAR(0x2243610)) called at /home/sand/src/perl/repoperls/installed- +perls/perl/perl-5.8.9/5da8/lib/5.8.9/Test/Builder.pm line 936 Test::Builder::_unoverload_str(Test::Builder=HASH(0x22b5120), SCAL +AR(0x2243610)) called at /home/sand/src/perl/repoperls/installed-perl +s/perl/perl-5.8.9/5da8/lib/5.8.9/Test/Builder.pm line 822 Test::Builder::ok(Test::Builder=HASH(0x22b5120), undef, "use LaTeX +::Encode;") called at /home/sand/src/perl/repoperls/installed-perls/p +erl/perl-5.8.9/5da8/lib/5.8.9/Test/More.pm line 968 Test::More::use_ok("LaTeX::Encode") called at t/00-basic.t line 12 # Looks like your test exited with 255 before it could output anything +.

The error is again being raised from deep in the test suite, but I have other modules which properly work with use_ok here. What could be different here?

Comment on taint-mode failures only on Perl 5.12 and lower?
Download Code
Replies are listed 'Best First'.
Re: taint-mode failures only on Perl 5.12 and lower?
by Anonymous Monk on Mar 24, 2014 at 12:13 UTC
    Why does your test have  #!/usr/bin/perl -T ? Get rid of that :)
        Thanks! That fixed it.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1079510]
Approved by ww
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (9)
As of 2015-07-08 03:15 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (93 votes), past polls