Beefy Boxes and Bandwidth Generously Provided by pair Networks
Just another Perl shrine

Re: trouble installing LWP and SVN::Core

by oiskuu (Friar)
on Jun 12, 2014 at 14:53 UTC ( #1089698=note: print w/ replies, xml ) Need Help??

in reply to trouble installing LWP and SVN::Core

There are tickets on this problem rt://94844, rt://53714.

Release tarballs ought to be sanitized (single toplevel folder; sane permissions, times; stripped or plain usernames/uids).
Also, for maximum compatibility, it is recommended that ustar format be selected:

tar --format ustar ...
Both GNU tar and bsdtar recognize this option.

Comment on Re: trouble installing LWP and SVN::Core
Replies are listed 'Best First'.
Re^2: trouble installing LWP and SVN::Core
by bluethundr (Pilgrim) on Jun 15, 2014 at 01:58 UTC
    Ok thanks guys! I've actually gotten over the hurdle of getting LWP installed.
    [root@uszmpaplp005lc ~]# perl -e 'while (<@INC>) { while (<$_/*.pm>) { + print "$_\n"; } }' | grep -i lwp /usr/local/lib/perl5/site_perl/5.20.0/

    And I'm now to a point where I can attempt to install SVN::Core. And when I do I cam running into a new error:
    checking for APR-util... no configure: WARNING: APRUTIL not found The Apache Portable Runtime Utility (APRUTIL) library cannot be found. Either install APRUTIL on this system and supply the appropriate --with-apr-util option or get it with SVN and put it in a subdirectory of this source: svn co \ \ apr-util Run that right here in the top level of the Subversion tree. Afterwards, run apr-util/buildconf in that subdirectory and then run configure again here. configure: error: no suitable APRUTIL found configuring SVN failed at inc/My/SVN/ line 118, <STDIN> line + 3. Something went wrong with the Subversion configuration. Please attempt to correct it and re-run Build.PL. Warning: No success on command[/usr/local/bin/perl Build.PL] MSCHWERN/Alien-SVN-v1.7.17.1.tar.gz /usr/local/bin/perl Build.PL -- NOT OK

    It looks like at this point the installation process can't find my APRUTIL install.

    I do have RPM installs of apr and apr-util installed.
    root@uszmpaplp005lc Alien-SVN-v1.7.17.1# rpm -qa | grep apr

    Can someone please help me get past this point? Thanks

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1089698]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others exploiting the Monastery: (6)
As of 2015-11-28 14:10 GMT
Find Nodes?
    Voting Booth?

    What would be the most significant thing to happen if a rope (or wire) tied the Earth and the Moon together?

    Results (742 votes), past polls