Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

RE: MP3 server with IO::Socket

by Anonymous Monk
on May 11, 2000 at 00:52 UTC ( #11054=note: print w/ replies, xml ) Need Help??


in reply to MP3 server with IO::Socket

It doesn't play the song for me. Just cycles through them all randomly without playing.


Comment on RE: MP3 server with IO::Socket
RE: RE: MP3 server with IO::Socket
by perlmonkey (Hermit) on May 11, 2000 at 01:40 UTC
    If the server is not writting anything to the socket, then it was not able to open the song, or your client is just disconnecting. Make sure the server has acess to read all the songs in your playlist. The playlist should have one song per line, with the absolute path (ie /usr/lcoal/share/music/mysong.mp3 or something like that).

    If that doesnt help, then what is your actuall error. It could be a problem with your mp3 client. I assume you can play music with the client without the server?

    If you cant resolve your problem, provide a more exact description of the problems. Or try to step through it with the debugger.

    You can always telnet to the server (assuming it is running on port 8000) and see the file contents being written to you. telnet localhost 8000 This will cause the server to spew out the file contents. If no random characters appear on your screen, then the server was not able to open any files in you playlist.
      It's printing out the song, and it's sending it to the port, but it's cycling through songs VERY fast.
        Well if you telnet to the port and it is printing the binary to the screen, then the server works. That is all it does. The whole purpose is to print binary to the socket. I would bet that the problem lies in your mp3 player, what player are you using and what OS are you using. I have been using this server in some form or another for about a year now, so I nearly positive that the problems you are having are not related to the server code (unless they are OS specific, in which case I probably cant help). But if you can track down the problems and the cause does lay in my code, then let me know and I will make the corrections.
Re^2: MP3 server with IO::Socket
by Anonymous Monk on Oct 07, 2007 at 15:01 UTC
    I was having a problem getting XMMS to play. Connecting to the server in Firefox though I could see the server was sending data. I was using XMMS 1.2.10. I turned the prebuffer percent to 0% for libmpg123.so plugin and it worked fine after that.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11054]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (12)
As of 2014-10-21 19:37 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (107 votes), past polls