Beefy Boxes and Bandwidth Generously Provided by pair Networks
We don't bite newbies here... much
 
PerlMonks  

Re: Trouble with TMPL_LOOP assignment

by George_Sherston (Vicar)
on Oct 18, 2002 at 17:54 UTC ( #206385=note: print w/replies, xml ) Need Help??


in reply to Trouble with TMPL_LOOP assignment

This looks like a problem with the data structure you're feeding to HTML::Template. Try
use Data::Dumper; print Dumper(\@liblog);
to see what you've got. Also to get interesting info about what went wrong,
use CGI qw/:standard/; use CGI::Carp qw(fatalsToBrowser warningsToBrowser); print header;
at the head of your script will give you the useful HTML::Template error info, inter alia.

Specifically in your case I may well be missing a bit of syntax, but I think %$item->{'ActionID'} probably ought to be $item->{'ActionID'} - otherwise you'll get an annoyingly interesting data structure? Or, did you initialise $viewliblog_page as an HTML::Template object? - this isn't clear from the chunk you posted

Also, you could save a bit of effort by modifying the elements in @log rather than creating a new array, as in
for my $item (@log) { $item->{UID} = GetItemFromDB('RealName','UID',$item->{'UID'},'User +') $item->{ActionID} = GetItemFromDB('ActionName','ActionID',$item->{ +'ActionID'},'Action'); }


George Sherston

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://206385]
help
Chatterbox?
[NetWallah]: /stevieb I dont understand - the poster had a very legitimate issue, and expressed it clearly. WHat did you have a problem with?

How do I use this? | Other CB clients
Other Users?
Others imbibing at the Monastery: (15)
As of 2017-02-23 14:53 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Before electricity was invented, what was the Electric Eel called?






    Results (347 votes). Check out past polls.