Beefy Boxes and Bandwidth Generously Provided by pair Networks
The stupid question is the question not asked
 
PerlMonks  

PPM errors, wrong pool

by blackstarr (Friar)
on Mar 12, 2003 at 16:55 UTC ( #242432=perlquestion: print w/ replies, xml ) Need Help??
blackstarr has asked for the wisdom of the Perl Monks concerning the following question:

I'm puzzled. (nothing new there!)

I've got ActiveState Perl 5.8 on Win 2000 Pro. I'm downloading the 5.8 ppd packages from Activestate & installing them with "ppm install $packageName.ppd". Every so often perl sends a pop-up telling me it's teminating because "the memory could not be 'written'", and this message appears at the bottom of my shell output:
Free to wrong pool 15d2850 not 3e3f2238 at C:\Perl\site\lib\ppm-conf\ppminst.bat line 781

At line 781, ppminst.bat has: print PPMXML <<INSTPKG;
... which means nothing to me.

Could the wise monks please:
1.) Explain what the problem is.
2.) Explain the cause.
3.) Explain the fix.

So Long
blackstarr

Comment on PPM errors, wrong pool
Re: PPM errors, wrong pool
by PodMaster (Abbot) on Mar 12, 2003 at 18:13 UTC
    Please always (in the least) post a `perl -v' dump. Also, a `perl -V' can't hurt (esp if you're having trouble with XS).

    Now, I got ActivePerl 5.8 build 804 on Win2k

    I use PPM very often and have never encountered that particular problem. Chances are its most likely a problem with your build, rather than ppm specifically.

    Also, the PPM shell has always sucked, and in such cases, you should always try to use PPM, for example

    perl -MPPM -e"PPM::InstallPackage( package => 'http://crazyinsomniac.p +erlmonk.org/perl/ppm/5.8/Devel-Size.ppd');" #!/usr/bin/perl use PPM; my $pack = 'http://crazyinsomniac.perlmonk.org/perl/ppm/5.8/Devel-Size +.ppd'; PPM::InstallPackage( package => $pack );
    Now, can you replicate the error you are seeing at will? How can I replicate it?


    MJD says you can't just make shit up and expect the computer to know what you mean, retardo!
    I run a Win32 PPM repository for perl 5.6x+5.8x. I take requests.
    ** The Third rule of perl club is a statement of fact: pod is sexy.

      Sorry to be so tardy with my reply ... I'm working 18/24 at the moment!

      My perl -v is EXACTLY the same as yours.

      I decided to try a fresh install so I:
      1.) Installed Perl (Same as above) on my other workstation (also W2k PRO)
      2.) Downloaded all the ActiveState 8xx .ppm modules & created a local repository (have to do that, the firewall doesn't like ppm)
      3.) Fired up PPM shell:
      3.a) search *
      3.b) install 1 - 2510
      4.) WAAAIIIITTTTEEEEDDDDD!
      5.) Received original error message right at end! Just once.
      6.) Tested ... modules seem to be installed fine!
      7.) Scratched head in puzzlement ... AGAIN!

      I do NOT get this problem on my Win98 system at home. Haven't tried the Redhat one.

      So Long
      blackstarr

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://242432]
Approved by Mr. Muskrat
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (16)
As of 2015-07-02 21:32 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (45 votes), past polls