Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation

Re: Cygwin Pod::Usage malfunction?

by stefan k (Curate)
on May 21, 2004 at 14:38 UTC ( #355285=note: print w/replies, xml ) Need Help??

in reply to Cygwin Pod::Usage malfunction?

the last time I tracked a problem with POD for quite a while it was due to different line endings. My suggestion would be to double- and triple check the \n and \r's in your code.

Of course I can't promise that this is _it_. Please consider this "just another hint". :-)

Regards... Stefan
you begin bashing the string with a +42 regexp of confusion

Replies are listed 'Best First'.
Re: Re: Cygwin Pod::Usage malfunction?
by Ambidangerous (Scribe) on May 21, 2004 at 15:25 UTC


    That was the magic bullet. Thanks, Stefan!

    What happened:

    Evidently I have a lazy text editor (however, it has support for DOS/Unix line endings, AND can do Unicode).

    When I took '' and saved it as '' with Unix line endings, there was no difference. When I took '' and saved it as '' with Unix line endings, it worked! Until I changed the name, it didn't feel like it needed to do any work converting line endings.

    That solves the problem. All I have to do is convert over my template files to the correct endings, and I'm good to go.

    Thanks again!

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://355285]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others avoiding work at the Monastery: (11)
As of 2016-10-24 19:23 GMT
Find Nodes?
    Voting Booth?
    How many different varieties (color, size, etc) of socks do you have in your sock drawer?

    Results (309 votes). Check out past polls.