in reply to To initialise or not to initialise?
It's more work definitely but it generally makes the code more readable (for instance, if I've no idea what 'page' means, I at least know the variable $page is going to be used for some numerical value).
If you have no idea what $page means, then, IMO, the name is not descriptive enough. If you use $page_nr, that would make it clear that it's used for a numerical value. $page could just as well contain a string with a PostScript rendition of a page.