Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl: the Markov chain saw
 
PerlMonks  

Can't install XML::LibXML

by Anonymous Monk
on Jul 04, 2005 at 03:02 UTC ( #472115=perlquestion: print w/ replies, xml ) Need Help??
Anonymous Monk has asked for the wisdom of the Perl Monks concerning the following question:

seems unusable -- can't get it to install, can't get dependencies worked out. Looks like from boards the land over other people have the same problems. Is there another alternative? Is there some deep secret locked in the mountains of perl that allows libxml to be used?

Edited by Arunbear: Changed title from 'XML::LibXML', as per Monastery guidelines

Comment on Can't install XML::LibXML
Re: Can't install XML::LibXML
by ysth (Canon) on Jul 04, 2005 at 05:08 UTC
    Can you describe what went wrong?

    Also, suggestions for alternative XML modules (there are many) will be better tailored to your situation if you describe what it is that you want to do with XML.

Re: Can't install XML::LibXML
by grantm (Parson) on Jul 04, 2005 at 08:38 UTC

    The XML::LibXML module provides an XS wrapper around the libxml2 library so if you're building from source then a compiler is required. But building from source is not usually required. A PPM for ActivePerl on Windows is available as documented in the Perl XML FAQ. For Linux, simply install the appropriate package from your distribution (eg: 'apt-get install libxml-libxml-perl' on Debian) and dependencies will be resolved automatically.

    If you have a problem that you want help to solve, then perhaps you might like to tell us what you tried and what happened.

      i can't install XML::LibXSLT on debian etch see the reaction one stubborn package, XML::LIBXSLT won't install. >> >> It looks like it may work, then: >> >> /usr/bin/ld: cannot find -lgdbm >> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< >> collect2: ld returned 1 exit status >> make: *** blib/arch/auto/XML/LibXSLT/LibXSLT.so Error 1 >> /usr/bin/make -- NOT OK >> Running make test >> Can't test without successful make >> Running make install >> make had returned bad status, install seems impossible please help to mee my email bensumfr@yahoo.fr

        Do you have libgdm? apt-get install libgdbm3 should get it for you.

        Also please read the formatting information when posting, Writeup Formatting Tips.

Re: Can't install XML::LibXML
by BaldPenguin (Friar) on Jul 04, 2005 at 08:45 UTC
    I don't know if this is the case, but the last time I went to install something with XML::LibXML using CPAN, it would'nt load install the dependant class, XML::LibXML::Common. After I loaded it seperatly, all went well.

    Don
    WHITEPAGES.COM | INC

    Edit by castaway: Closed small tag in signature

      This worked for me! In fact, I executed install XML::LibXML::Common and that installed XML::LibXML completely.
Re: Can't install XML::LibXML
by planetscape (Canon) on Jul 31, 2005 at 05:21 UTC

    If you are running ActiveState 5.8x, get the PPM from here.

    If ActiveState 5.6x, get it from here.

    In either of the above cases, OR if you are running Cygwin, install XML::LibXML::Common FIRST.

    HTH,

    planetscape
      hi
      this is also a good link where you can see and resolve this problem
      http://perl-xml.sourceforge.net/faq/#win32_expat
      Ashwani

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://472115]
Approved by ysth
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others musing on the Monastery: (9)
As of 2014-09-16 19:13 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (45 votes), past polls