Beefy Boxes and Bandwidth Generously Provided by pair Networks
The stupid question is the question not asked
 
PerlMonks  

Re^4: PPM Hell: "PPM::PPD::init: not a PPD and not a file"

by tphyahoo (Vicar)
on Aug 16, 2005 at 13:37 UTC ( #484151=note: print w/ replies, xml ) Need Help??


in reply to Re^3: PPM Hell: "PPM::PPD::init: not a PPD and not a file"
in thread PPM Hell: "PPM::PPD::init: not a PPD and not a file"

Thanks again podmaster.

Well, to be honest, I don't really understand LWP::Debug, although thanks to your post this is now on my list of things to learn. What I copied in my last post was straight out of the dos window, without skipping anything.

Also, I don't think it's a proxy issue; my location is germany.

But, I solved this issue without lwp debug. This was possible because, like I originally thought, the problem has to do with dependencies not installing "automagically" like I would exect with ppm.

I determined the following dependencies chain, basically by reading the ppd definitions in the various ppd urls:

http://theoryx5.uwinnipeg.ca/ppms/PAR-WebStart.ppd requires http://theoryx5.uwinnipeg.ca/ppms/XML-SAX-ExpatXS.ppd requires http://theoryx5.uwinnipeg.ca/ppms/XML-SAX.ppd which requires <INSTALL EXEC="PPM_PERL" HREF="http://theoryx5.uwinnipeg.ca/ppms +/scripts/install_libexpat">install_libexpat</INSTALL>
This last "INSTALL EXEC" thing basically walks the user through copying a dll file into somewhere accessible by PATH. It appears to be this step which gums up the works.

When I did ppm install http://theoryx5.uwinnipeg.ca/ppms/XML-SAX.ppd, including copying the dll, then ppm install http://theoryx5.uwinnipeg.ca/ppms/XML-SAX-ExpatXS.ppd, then finally ppm install http://theoryx5.uwinnipeg.ca/ppms/PAR-WebStart.ppd, I was finally able to install PAR-WebStart okay.

I then deleted the dll and uninstalled all three modules with ppm uninstall module, and reinstalled, to see if I could recreate the problem. It turns out that

ppm install http://theoryx5.uwinnipeg.ca/ppms/PAR-WebStart.ppd

gives the same unhelpful error as before, but

ppm install http://theoryx5.uwinnipeg.ca/ppms/XML-SAX-ExpatXS.ppd

installs its depdendency, the dll, and itself, with no problem. On the initial install, I *think* ppm install XML-SAX-ExpatXS failed out with the same mysterious error as PAR-WebStart, but I can't recreate this. Could it be the dll got registered somehow even though I deleted it? I wish I had a fresh computer to try this out on. Well, maybe my memory is playing tricks on me.

In any case, I have succeeded in recreating that PAR-WebStart has trouble initiating the automatic installation of its XML-SAX-ExpatXS dependency.

I hope this is helpful to monks that have experienced the same PPM hell problems that I have. If someone knowledgable in ppm has any further light to shed on this, or workarounds, or ways to make something that should be easy, really easy, that would be great.

PodMaster, again I totally appreciate the handholding. Even though it appears this wasn't a dns thing, your feedback kept me going on something that has been annoying me for months.

I guess I finally will drop randy kobes a line about this as well.


Comment on Re^4: PPM Hell: "PPM::PPD::init: not a PPD and not a file"
Select or Download Code
Re^5: PPM Hell: "PPM::PPD::init: not a PPD and not a file"
by randyk (Parson) on Sep 05, 2005 at 02:02 UTC

    One possible explanation for this might be connected with the list of repositories used when following dependencies. For example, using the notation of PPM::Repositories, assuming ActivePerl 8xx, an ordered repository list of

    1. theory
    2. theory58
    3. ActiveState Package Repository
    4. ActiveState PPM2 Repository
    will cause an error about "no suitable installation target found" when trying to install a package common to both the theory and theory58 repositories; for example,
       ppm> install Crypt-RSA
    
    This is because the theory repository is for ActivePerl 6xx packages, and theory58 is for ActivePerl 8xx packages; however, the ppm utility will stop at the first matching package found, and then abort if it's not for the correct platform, even though a correct platform is available further down in the repository list.

    One thing perhaps worth trying is to go through the repository list and remove any repositories that are specific to perl-5.6 (if you're using perl-5.8).

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://484151]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (8)
As of 2014-07-30 12:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (231 votes), past polls