So far as making this OO, I wrote something vaguely similar to this recently, in that it had rows of mostly identical widgets to collect user input. I decided that a "row" was a good candidate to be made a class. On a level above that, you could have a "grid" or "row collection" class that handles things like adding and removing rows to a list or grid. Each of those classes would be partially handling some widgets.
in reply to Name spaces and Perl::Tk coding style
In addition to being easier to read, the good thing about this is that in my app you can add and remove rows dynamically. So when you click a button it just calls "add_row()"; click another and it calls "remove_row()". The "grid" object would handle that, and it can make sure you don't have less than $MIN_ROWS rows or more than $MAX_ROWS rows, and keep track of the current number of rows, etc. etc.
Depends what your requirements are though. Only use OO if it makes sense to use it.