Beefy Boxes and Bandwidth Generously Provided by pair Networks DiBona
Welcome to the Monastery
 
PerlMonks  

Why can't I install the DBI module?

by rodry (Beadle)
on Mar 27, 2000 at 20:33 UTC ( #6242=perlquestion: print w/ replies, xml ) Need Help??
rodry has asked for the wisdom of the Perl Monks concerning the following question:

I tried to install DBI following all the instructions carefully. I get all kinds of cryptic error messages. Can anyone tell me of some obvious mistakes I may be making in the installation process?

Comment on Why can't I install the DBI module?
Re: Why can't I install the DBI module?
by ishamael (Beadle) on Apr 14, 2000 at 02:18 UTC
    if you are running perl 5.6, DBI (1.13) has a few issues one must solve.
    edit the DBI.xs file, and search for SHORT-CUT ALERT this will be followed by a medium sized if-else comment out (using C style comments) everything needed so that the else function is the only thing there, and always run
    itll look like this:
    /* SHORT-CUT ALERT! */ /* if (xsbypass && isGV(imp_msv) && CvXSUB(GvCV(imp_msv))) { I32 markix = TOPMARK; CV *xscv = GvCV(imp_msv); (void)(*CvXSUB(xscv))(xscv) if (gimme == G_SCALAR) { if (++markix != stack_sp - stack_base ) { if (markix > stack_sp - stack_base) *(stack_base + markix) = &sv_undef; else *(stack_base + markix) = *stack_sp; stack_sp = stack_base + markix; } outitems = 1; } else { outitems = stack_sp - (stack_base + markix); } } else {*/ outitems = perl_call_sv(isGV(imp_msv) ? (SV*)GvCV(imp_msv) + : imp_msv, gimme); /* }*/

    if youre not using 5.6, or if this doesnt solve it please post more information.
Re: Why can't I install the DBI module?
by ask (Pilgrim) on Apr 12, 2001 at 12:32 UTC
    rodry,

    what version of DBI, what platform and more exactly what error messages are you getting?

    - ask

Re: Why can't I install the DBI module?
by snapdragon (Monk) on Apr 18, 2001 at 12:51 UTC
    The DBI module can be a bit of a pain to install. I'm assuming that you're installing as root and that all the environment variables are set up OK (e.g. the path to perl is set up, gcc can be found, etc.).

    The standard install is the usual for any perl module:

    perl Makefile.PL make make test make install

    If you can get as far as the make test then I'd recommend trying a make test TEST_VERBOSE=1. This will give more useful output on what is going on. If you still have problems may I suggest posting back with details of the DBI version and also the output of a perl -V.

    Good Luck.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://6242]
Approved by root
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others studying the Monastery: (9)
As of 2014-04-18 07:17 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (463 votes), past polls