Avoiding $a and $b in perl is particularly good advice (due to the overlap with the sort magic variables).
in reply to Using $a and $b for sort
But it's also a good idea to avoid them since they aren't meaningful names. I think one of the most important parts of writing code is choosing good names for variables (and functions, and all name-able things). I don't mean needlessly long names, but appropriate names (name length should in general be loosely proportional to variable scope - if that gives you long names you want smaller scope for your variables).
Yes, you have to stop and think about a good name, but it makes the code much more readable. Compare: $page->render(); with $tmp->do_it().
It's also important to change names if you change the code, so they stay accurate. (e.g. change a variable from $employee to $person if you make a routine more general).