Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Re: Mail::Sendmail Multipart MIME isn't working

by blahblahblah (Priest)
on Jun 28, 2008 at 01:13 UTC ( #694472=note: print w/ replies, xml ) Need Help??


in reply to Mail::Sendmail Multipart MIME isn't working

I have a guess: does it work correctly if you remove the following line?

$html = encode_entities($html);
I suspect that the example you linked to is expecting non-html text as input and is therefore encoding all entitites, whereas your data has html tags that you want left alone.


Comment on Re: Mail::Sendmail Multipart MIME isn't working
Download Code
Re^2: Mail::Sendmail Multipart MIME isn't working
by cormanaz (Chaplain) on Jun 28, 2008 at 16:56 UTC
    I tried that. I also added $html = encode_qp $html; because I think the HTML has to be quoted printable to be used in MIME. That works much better, i.e., the message gets interpreted as HTML.

    OTOH now all the quotes are disappearing from the HTML. Anyone know why that is?

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://694472]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (14)
As of 2014-09-17 17:05 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (92 votes), past polls