Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re: fastcgi broke my Exports

by perrin (Chancellor)
on Jul 13, 2009 at 19:44 UTC ( #779735=note: print w/ replies, xml ) Need Help??


in reply to fastcgi did NOT break my Exports, issue now resolved

Your example code looks ok. Could you tell us more about how you run FastCGI, i.e. which perl module you're using?


Comment on Re: fastcgi broke my Exports
Re: fastcgi broke my Exports
by hesco (Deacon) on Jul 13, 2009 at 20:19 UTC
    Thanks perrin:

    I should have clarified. This application is still running under mod_cgi (or at least that was my intention). I installed fastcgi to run a couple of instances of RequestTracker on the same machine. The RT vhost container looks like this:

    <VirtualHost 192.168.1.5:80> ServerName rt1.example.com DocumentRoot /usr/local/rt-3.8.4/share/html CustomLog /var/log/apache2/rt1_access.log combined ErrorLog /var/log/apache2/rt1_error.log AddHandler fastcgi-script fcgi ScriptAlias / /usr/local/rt-3.8.4/bin/mason_handler.fcgi/ </VirtualHost>
    I would like to run this new application under fastcgi one of these days, but it was written as a CGI application and I had not counted on having to refactor this code just yet, just to host RT on the same box where I'm building this.

    Is it not possible to run mod_cgi and mod_fastcgi at the same time on the same apache server? And if not, can anyone recommend a good tutorial to guide such a refactoring of essentially working code? I was well on the path to a beta launch before this little hickup.

    -- Hugh

    if( $lal && $lol ) { $life++; }
      There's no reason this should interfere with existing CGI code if you run them on separate virtualhosts. If you comment this out, do your scripts start working again?
        No, it does not. I still get those same errors:Can't locate object method "_GenerateAccountSummary" via package , even though that is a valid method in my ::Account module, use'd by my base class.

        It was a long weekend, but as I ponder this, more of it is coming back to me.

        I'm working on a Debian server. The previous weekend I had installed mod_perl, until I encountered namespace clashes when I attempted to run a second instance of RT on the same apache. Further research led me to believe that fastcgi would bypass that issue.

        But when it came time to install fastcgi, I ran into some conflicts with respect to the pre-requisites. In order to resolve those, I wound up doing an `apt-get dist-upgrade`. I then had to completely rebuild my site's perl lib, most of it from cpan.

        I was focused on making RT work. I did not come back to testing this application under development until I had those two RT instances up and running. And that is when I encountered this issue.

        I don't know if that sheds any light on this situation or not. But perhaps it was not fastcgi which broke Exporter, but something else I did in that move from Etch to Lenny, in order to get fastcgi working.

        I'm baffled, here.

        -- Hugh

        if( $lal && $lol ) { $life++; }

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://779735]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (5)
As of 2014-10-23 10:36 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (125 votes), past polls